View Single Post
Old 03-16-07, 06:08 AM   #10
wernerf
Registered User
 
Join Date: Mar 2007
Location: Nuernberg, Germany
Posts: 6
Default Re: FX 5200 DVI: No valid modes for "1680x1050"; removing.

FX 5200 DVI: No valid modes for "1680x1050"; removing. Solved.

Yesterday I had a boot orgy.
All my tests with some settings in xorg.conf had the effect that the X server
works only once a time (on the DVI connector). I had the idea that after a stop of the X server the graphiccard or driver switch to the analog connector.
Anyway the LCD monitor doesn't get a signal, but the x server can be started again, because a audio output (started by KDE's autostart) started.

All my defined modelines in the "Mode" section was't ignored by the driver.

At least the following option solves my problem:

Option "UseEDIDFreqs" "false"
Option "ModeValidation" "DFP-0: NoMaxPClkCheck, NoEdidMaxPClkCheck, AllowNon60HzDFPModes"

in the section "Device".
With this also the multiple start of the X server works again.
Via "startx -- -logverbose 6" I found no3w in the file "/var/log/Xorg.0.log":

(II) NVIDIA(0): Mode Validation Overrides for LG L204WT (DFP-0):
(II) NVIDIA(0): AllowNon60HzDFPModes
(II) NVIDIA(0): NoMaxPClkCheck
(II) NVIDIA(0): NoEdidMaxPClkCheck
(II) NVIDIA(0): Frequency information for LG L204WT (DFP-0):
(II) NVIDIA(0): HorizSync : 30.000-83.000 kHz
(II) NVIDIA(0): VertRefresh : 56.000-75.000 Hz
(II) NVIDIA(0): (HorizSync from HorizSync in X Config Monitor section)
(II) NVIDIA(0): (VertRefresh from VertRefresh in X Config Monitor
(II) NVIDIA(0): section)
(II) NVIDIA(0):
(II) NVIDIA(0): --- Building ModePool for LG L204WT (DFP-0) ---
(II) NVIDIA(0): Validating Mode "1680x1050":
(II) NVIDIA(0): 1680 x 1050 @ 60 Hz
(II) NVIDIA(0): For use as DFP backend.
(II) NVIDIA(0): Mode Source: EDID
(II) NVIDIA(0): Pixel Clock : 146.25 MHz
(II) NVIDIA(0): HRes, HSyncStart : 1680, 1784
(II) NVIDIA(0): HSyncEnd, HTotal : 1960, 2240
(II) NVIDIA(0): VRes, VSyncStart : 1050, 1053
(II) NVIDIA(0): VSyncEnd, VTotal : 1059, 1089
(II) NVIDIA(0): H/V Polarity : -/+
(II) NVIDIA(0): Mode is valid.

Much Thanks for all to help me to solve the problem.

Werner
wernerf is offline   Reply With Quote