View Single Post
Old 03-18-07, 11:05 AM   #1
MethylMaus
Registered User
 
Join Date: Mar 2007
Posts: 1
Default GPU Fan runs at full speed

Greetings!

My apologies if this has been asked in another thread, there are so many to search through I hope I did not miss this answer if it was there.

I am currently using the nVidia Linux driver version 1.0-9746. Whenever any program makes any call whatsoever to openGL the GPU fan on my card turns on to maximum speed. For example, I would open the nVidia configuration panel and when I click on the "OpenGL/GLX information" the fan spins up to full speed and will stay at that speed for approximately 2-3mins after I have left the screen. Similarly the fan also revs the instant any game or program using openGL starts up.

Now I know my GPU is not getting hot enough in most of these situations (even running Beryl or Compiz) to warrant a full speed fan. Is there anything I can do to prevent this from happening? I've done quite a bit of searching and have not found much, but a few forms mentioned that the Linux driver does not correctly report the temperature of the GPU when openGL starts and thus revs the fan. However looking at the thermal monitors provided in the settings panel it reports the temperature to be between 45-50 C most of the time, the bar graph is green so I assume this is a safe idle/operating temperature.

My specs are as follows:
Slackware Linux (Custom 2.6.20 kernel)
nVidia Linux drivers version 1.0-9746
EVGA nVidia GeForce 7900GT KO
nVidia GeForce 4 SLI chipset

Thank you, your help is greatly appreciated!
MethylMaus is offline   Reply With Quote