View Single Post
Old 03-20-07, 05:22 AM   #1
Roger D
Registered User
 
Join Date: Mar 2007
Posts: 4
Default Changing screen resolution to 1400x900

Hi

When I installed 60.06, on my new PC it correctly detected my Samsung 1280x1024 monitor. Now I want to switch to a new monitor with a resolution of 1400x900.

I've integrated Nvidia GeForce 6150 graphics on my motherboard. I've installed the drivers via Automatix. I'm sure this has worked, because Nvidia settings appears under Applications>System tools, and I can play the 3D game Briquolo. I was using my old Samsung monitor when I downloaded the drivers using Automatix, but I don't think this would make any difference.

I've tried running sudo dpkg-reconfigure xserver-xorg, but get the message "No X server known for your video hardware", which seems a bit unlikely, so I tried editing my xorg.conf file. Here's the relevant section of the amended file:

Section "Monitor"
Identifier "SAMSUNG"
Option "DPMS"
HorizSync 30-80
VertRefresh 56-75
# 1400x900 @ 75.00 Hz (GTF) hsync: 70.50 kHz; pclk: 132.54 MHz
Modeline "1400x900_75.00" 132.54 1400 1488 1640 1880 900 901 904 940 -HSync +Vsync

EndSection

Section "Device"
Identifier "Generic Video Card"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Generic Video Card"
Monitor "SAMSUNG"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1400x900" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1400x900" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1400x900" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1400x900" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1400x900" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1400x900" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
EndSubsection

My new monitor, which seems to be some sort of generic brand, has a horizontal frequency 30-80MHz and a vertial refresh rate of 56-75 Hz.

So, I far as I can tell, the xorg.conf file is now right. The monitor brand name is wrong, but I can't see this making any difference.

Unfortunately, this changes haven't made any difference. The resolution is still 1280x1024. And, yes, I did Ctl+Alt+backspace to reboot my PC

The Nvidia settings window looks as though it might be useful, but I can't see how I'd use it to change the screen resolution.

All advice much appreciated.

Best regards

Roger D
Roger D is offline   Reply With Quote