View Single Post
Old 03-20-07, 01:16 PM   #1
dusdus
Registered User
 
Join Date: Mar 2007
Posts: 5
Default resolution and graphical issues

greetings,

My laptop, a Toshiba Satellite pro 6100 is a second hand one and I love 'm
Finally I got the Nvidia GeForce2 420 Go up and running, using the Envy-script to install the correct driver. I'm using ubuntu 6.10, downloaded yesterday
After installing the nvidia driver I got sounds, the system up and running, though a black screen.
It seemed I needed to add something to my xorg.conf:
Option "UseDisplayDevice" "DFP"

and indeed, that did the trick.

Problem now is, I can't change the resolution and I have some frustrating black stripe to the right of my screen; which is about 1.5 inch wide.
Chosing System --> Preferences --> Screen Resolution I can only chose 800x600 and 640x480. The refresh rate can be 50 or 52.

Before installing the nvidia drivers the resolution was 1024x768, and if I remember correctly the refresh rate was 60.

So I tried and it seems a lot of people have this problem.
As I dont know the actual sync and refresh rates, I had to try some generic ones:
Code:
Section "Device"
	Identifier	"NVIDIA GeForce4 420 Go"
	Driver		"nvidia"
	BusID		"PCI:1:0:0"
	Option		"UseFBDev"		"true"
	Option		"UseDisplayDevice"	"DFP"
	Option "IgnoreEDID" "1"
	Option "UseEdidFreqs" "0"
EndSection

Section "Monitor"
	Identifier	"Generic Monitor"
	Option		"DPMS"
	HorizSync	33-75
	VertRefresh	55-70
# 1024x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 64.11 MHz
  Modeline "1024x768_60.00"  64.11  1024 1080 1184 1344  768 769 772 795  -HSync +Vsync
EndSection
As you can see I've been experimenting a little with the lines IgnoreEDID etc, trust me also without those lines it simply wont work.

Code:
Section "Screen"
	Identifier	"Default Screen"
	Device		"NVIDIA GeForce4 420 Go"
	Monitor		"Generic Monitor"
	DefaultDepth	16
	SubSection "Display"
		Depth		1
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1024x768" "800x600" "640x480"
	EndSubSection
EndSection
I've read and done a lot of how-to's concerning this problem and I have this feeling I'm overlooking some simple thingy...


Ah and now I've just tested something new.

I've followed the instruction on this website:
http://doc.gwos.org/index.php/Latest...OBLEMS_SECTION

7) If you own a GeForce4 420/440 Go or a GeForce4 MX 440 you should follow these steps:

etc...

Now it looks like I have a better/ the correct resolution, though all fit in a smaller part of the screen.
So now the screen which I can see ubuntu in is surrounded with black bars/borders!
It looks sharper though :P

and still, the application: System -> Preferences -> Screen Resolution says: 800x600.

So anyone has some bright ideas?!
Attached Files
File Type: log nvidia-bug-report.log (89.9 KB, 119 views)

Last edited by dusdus; 03-20-07 at 01:23 PM. Reason: added logfile
dusdus is offline   Reply With Quote