View Single Post
Old 03-21-07, 05:41 AM   #1
okfineilldoit
Registered User
 
Join Date: Feb 2005
Posts: 9
Default panning screen in X...OK, I fixed it here's what and how: Gforce2 mx400,

My original problem showed up on my desktop computer after the installation of mandriva 2006, free downloaded DVD. I had been using a Compro Geforce2 mx400 Personal Cinema card with no problems for years with windows XP, and previous versions of linux and previous nvidia display drivers liked the combo. However,after this installation including the nvidia driver 9631, my desktop was an 800x600 box panning around a 1280x1024 virtual screen. That dorve me crazy for the last week. In X using the default "nv" driver I had no problems; a full list of standard resolutions and refresh rates, all available and functional. After switching to the Nvidia driver, I could only select the default monitor resolution(which could be panned around with only 800x600 visible,) or 800x600, both at a refresh rate of 50Htz.

After reading the installation readme file and all appended chapters (6 times,) and sorting through my verbose log file I found that the nvidia driver was reporting the refresh rate of my monitor as -1 to 0 Mhz, and consequently denying all possible modes. Normally I would think my monitor or video card to be broken down, but this is a dual boot system and the microsoft partition still works fine at 1600x1200 @100htz. As there were no valid modes, "nvidia-auto-select" punched in an acceptable mode of it's own selection with a virtual desktop of my default monitor size and a panning area of 800x600 at 50Htz (despite stating in the log file that anything over 0 was out of range.)
This is the default behavior of the driver.

FIRST BUG NOTICE
The only other thing that could be flawed is the nvidia driver's reporting of the EDID timings.

So the simple fix is to disable EDID, but the X config options appendix (app D) warns that you can disable certain EDID functions, rather than disable it all together. Since timings were an issue I tried "Option "UseEdidFreqs" "False"" but it had no effect. Since the overall error was in the validation of modes I went to "Option "ModeValidation" "NoEdidModes"" Also no effect. With both tried individually the log file still shows a range of -1 to 0 htz and all modes invalid.

SECOND BUG
These options are ineffectual!

The last resort was to disable EDID globally with " "Option" "NoEDID" " after that my desktop works like a desktop again. Problem solved. Fin. Now to get the tv tuner working....
okfineilldoit is offline   Reply With Quote