View Single Post
Old 03-24-07, 08:15 AM   #1
daminator
Registered User
 
Join Date: Mar 2007
Posts: 16
Default Slow nVidia 5200. 10 fps with glxgears!

Hello all,

I have a nVidia 5200 that doesn't seem to be working correctly. I'm using driver version 1.0.9746 installed both manually using a guide in the Ubuntu forum, and then again using the excellent "envy" installer.

When Ubuntu boots into the log in screen, the 'fade' seems to stutter, which I wouldn't expect. I also notice a lot of stuttering in Penguin Planet Racer (or whatever it's called). I only have a 1 gig athlon machine, but I would have thought the card could handle this just fine.

Then someone suggested I run 'glxgears -printfps' and I'm shocked to find that I get just over 10 fps. Any ideas what could be going on? Here's my xorg.conf



# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Fri Dec 15 10:12:14
PST 2006

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/X11/fonts/misc"
FontPath "/usr/share/X11/fonts/cyrillic"
FontPath "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/X11/fonts/Type1"
FontPath "/usr/share/X11/fonts/100dpi"
FontPath "/usr/share/X11/fonts/75dpi"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "dbe"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
Load "vnc"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "Monitor"
Identifier "ADI MicroScan 5G"
HorizSync 30.0 - 95.0
VertRefresh 50.0 - 160.0
ModeLine "1024x768_85.00" 94.4 1024 1088 1200 1376 768 769 772 807
-hsync +vsync
Option "DPMS"
EndSection

Section "Device"
Identifier "Nvidia Gforce FX-5200"
Driver "nvidia"
EndSection

Section "Screen"

# Option "metamodes" "1024x768_85 +0+0; 1280x1024 +0+0; 1024x768
+0+0; 800x600 +0+0; 640x480 +0+0"
Identifier "Default Screen"
Device "Nvidia Gforce FX-5200"
Monitor "ADI MicroScan 5G"
DefaultDepth 24
Option "SecurityTypes" "VncAuth"
Option "UserPasswdVerifier" "VncAuth"
Option "PasswordFile" "/root/.vnc/passwd"
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


I've also tried changing composite to disable based on one suggestion I had, but that didn't work either.

Any ideas?

Cheers
Damian
daminator is offline   Reply With Quote