View Single Post
Old 03-26-07, 02:21 PM   #1
gurkan
Registered User
 
Join Date: Mar 2007
Posts: 2
Default Can not enable Fast Write and SBA after nvidia-glx-legacy and big performance issues

Hi there,

I'm using GNU/Linux operating system with Ubuntu distribution. I have a Dell Latitude D800 model laptop and onboard GeForce4 Ti 4200 Go AGP 8x graphic card.

I already used nvidia-glx package for nvidia drivers. Today, after an dist-upgrade it does not work. As far as i understand that my graphic card is now in the legacy group. There is the Xorg.0.log output that when I use nvidia-glx;

(WW) NVIDIA(0): The NVIDIA GeForce4 4200 Go GPU installed in this system is
(WW) NVIDIA(0): supported through the NVIDIA 1.0-96xx Legacy drivers.
(WW) NVIDIA(0): Please visit http://www.nvidia.com/object/unix.html for
(WW) NVIDIA(0): more information. The 1.0-9755 NVIDIA driver will ignore
(WW) NVIDIA(0): this GPU. Continuing probe...
(EE) No devices detected.

Now i'm using nvidia-glx-legacy package (Version is: 1.0.7184+2.6.17.5-11). I prefer to use XGL with beryl for desktop manager. But after transition to legacy package, i can not enable fast writes and SBA. And another problem; it appears AGP Rate as 4x but it is 8X.. I can not assign it to 8x manually too. There is the /proc/driver/nvidia/agp/status file output;

Status: Enabled
Driver: AGPGART
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled

it was already enabled when i use nvidia-glx package. But after to legacy package, I can not force them to enable. To enable those functions, i already added next line to /etc/modprobe.d/nvidia-kernel-nkc file;

options nvidia NVreg_EnableAGPSBA=1 NVreg_EnableAGPFW=1

however, i can not enable them manually (I mean i tried manually use the modprobe command and passed the parameters but it retuns an error without any message. Just say something such as this: "error on load the module" etc. ).

Actually everything seems okay and there is no any error if i use nvidia-glx-legacy package without fast write and sba. But XGL and beryl are working so slow now. there is glxinfo for OpenGL if you need;

glxinfo |grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce4 4200 Go/AGP/SSE2
OpenGL version string: 1.5.3 NVIDIA 71.84
OpenGL extensions:

and i already added next lines to xorg.conf file (to Screen section);

Option "AllowGLXWithComposite" "True"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"

And i already enabled composite in the Extensions section...

Option "Composite" "Enable"

Now the questions are;

- Why i can't enable Fast Write and SBA with the legacy driver? Or how can i enable them?
- How can i solve the performance issues? Is there any trick to try?
- Why some of module options are not available in legacy module? (You can ceck them with "modinfo nvidia" command within nvidia-glx and nvidia-glx-legacy packages)
__________________
Gurkan ASLAN
Software Developer
gurkan is offline   Reply With Quote