View Single Post
Old 05-14-03, 10:20 PM   #12
stuartlevy
Registered User
 
Join Date: May 2003
Location: flat, steamy Champaign, IL
Posts: 36
Lightbulb Check out those errors: libGLcore.so.1: undefined symbol __nvsym14822

Looking at the "xf86-log-config.txt" brewer
posted, there are a couple of glaring
errors (look for "(EE)"):

(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
dlopen: /usr/lib/libGLcore.so.1: undefined symbol: __nvsym14822
(EE) Failed to load /usr/X11R6/lib/modules/extensions/libglx.so

Does this suggest that libGLcore.so
doesn't match the libglx.so XF86 extension?
I think both should be replaced when you
run the nvidia installer.

You could check

ls -l /usr/lib/libGLcore.so.1
ls -l /usr/X11R6/lib/modules/extensions/libglx.so

Each should be symlinks to similar files
named with the nvidia release version:
libGLcore.so.1.0.4363 and
libglx.so.1.0.4363 on my system.

nm -D ... | grep 14822 on each shows that
libGLcore.so.1.0.4363 has it undefined:
U __nvsym14822
while libglx.so.1.0.4363 defines it:
000a4a1c D __nvsym14822

so I bet you've got an older, or maybe
original XFree86, libglx.so installed.
stuartlevy is offline   Reply With Quote