View Single Post
Old 03-31-07, 05:59 PM   #1
nasete
Registered User
 
Join Date: Feb 2006
Posts: 15
Default Geforece 6400 GO + Beryl

Hi, i have a laptop with Geforece 6400 Go, i try with many configuration but i can't work beryl with aceptable performance.

My xorg.conf is correct (revised by beryl developer) and beryl don't say any error,always i post my conf.


Quote:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Mon Feb 26 23:38:46 PST 2007

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
EndSection

Section "Files"

# path to defoma fonts
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "type1"
Load "vbe"
Load "dbe"#Added by nat
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "es"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "InputDevice"
Identifier "stylus"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "eraser"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Identifier "cursor"
Driver "wacom"
Option "Device" "/dev/wacom" # Change to
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Monitor"
Identifier "Generic Monitor"
HorizSync 28.0 - 64.0
VertRefresh 43.0 - 60.0
Option "DPMS"
EndSection

Section "Device"
Identifier "nVidia Corporation NV43 [GeForce Go 6200/6400]"
Driver "nvidia"
Option "AllowGLXWithComposite" "True"
Option "RenderAccel" "True"
Option "BackingStore" "true"
EndSection

Section "Screen"

#TwinView
Identifier "Default Screen"
Device "nVidia Corporation NV43 [GeForce Go 6200/6400]"
Monitor "Generic Monitor"
DefaultDepth 24
Option "TwinView" "True"
Option "MetaModes" "nvidia-auto-select, nvidia-auto-select"
Option "TwinViewOrientation" "RightOf"
Option "TwinViewXineramaInfoOrder" "DFP"
#Beryl
Option "AddARGBGLXVisuals" "True"
#Screen
SubSection "Display"
Depth 24
Modes "1280x1024" "1280x800"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection
My beryl configuration is:
Rendering path: copy (if i use Texture from pixmap all screens will be black).
Rendering Platform: nvidia.

I use kubuntu feisty.

The laptop is a Sony Vaio vgn-F315S.
Cpu: 1,8Ghz intel centrino.
Ram: 1Gb.
VGA: Nvidia geforece Go 6400 with TurboCache.

In lshw say the VGA have 256Mb ram memory.

I use twinview with one 19"lcd with resolutions
LCD: 1280x1024 DFP: 1280x800.

I don't use metamodes because i don't like reconfigure my xorg.conf when i wan use my LCD or only my DFP.


Thx and sorry for my inglish.
nasete is offline   Reply With Quote