View Single Post
Old 04-02-07, 07:20 AM   #1
grey_1
Guest
 
Posts: n/a
Exclamation Vista games optimising

ltobias originally posted this, which is why I'm quoting his post first. Credit goes to him for this tweak, and to Greeno and nekrosoft13 for their help. This whole thing is re-edited over and over to try and consolidate tips and such...I'm just trying to get it all in one place. So there may be changes here and there as folks add tips and clarifications.

Once more - This isn't my tweak, and I don't understand it all. Use at your own risk, ymmv. Do not shoot the messenger please!

It started as a STALKER fix, but it appears to work with several games under several drivers, with both 64 and 32 bit. There is an extra step involved with 32bit...so read on and good luck.

This first part is all that's needed for 64bit Vista. This is ltobias' original quote.
Quote:
Quote:
Originally Posted by ltobias
No problem with Stalker and Vista64.

I'm only using this trick:


You need the explorer ( http://www.ntcore.com/exsuite.php )

You open with this explorer the XR_3DA.exe in the bin folder from stalker.

On the left side you will find "NT Header/File Header". Click on File Header.

On the right side click on "click here".

Now you need to enable "App can handle> 2gb adressest " and to save.

I recommend to backup the XR_3DA.exe befor editing.



Leif
Now Greenos quote, he posted this to me because I'm a n00b at this and needed help.

Quote:
Quote:
Originally Posted by Greeno
Now, I don't have S.T.A.L.K.E.R

But :-

"Now comes the additionally part for Vista32:

You have to go to start-program-equipment. Now you have to right click on input-request and start as Administrator.

Equals - "Start --> All Programs --> Accessories --> Run (As Administrator) It's important it says "This task will be created with administritive privileges"
Now enter: bcdedit /set IncreaseUserVA 3072

Simply paste :- bcdedit /set IncreaseUserVA 3072 and click run, you'll see a black screen pop up and disappear again quickly... reboot and you should be set... it's kinda like using the /3GB switch in XP.

After that you have to restart Vista. This is important!

He also wrotes:

The adress area for windows maschines is short and this trick only helps applications that are prepared to use more than 2 GB. Like the trick with "App can handle> 2gb adressest". You should only use the trick for exceptional cases."


- Hope that helps, although, perhaps it's the second part you're struggling with?
For me so far, confirmed on..

-STALKER
-FEAR
-UT2004
-Unreal 2

EDIT: Using Vista HP32bit
2 gigs ram
games patched to latest version
Seeing both increased fps, no crashes.

Second Edit: A quick guide with pics.

Here goes..

1.) First thing I did was download explorer here.

2.)After unzipping it and running the CFF Explorer.exe you'll see this.


Back up your .exe FIRST!!

3.)Click on the folder icon and navigate to your XR_3DA.exe.
It will be in C:\Program Files\THQ\STALKER\bin.

4.)Click on it, and when Explorer open it you'll see this.


5.)Click on File header, then to the right, where it says 'Click here'

You should get this.


6.)Check 'App can handle >2gb addressest.

7.)Close out of all and reboot.

This is all you need for 64bit Vista. Read on for the last step for 32bit.


On Home Premium I do not have an admin option for my run command. I did this, but if you have a better way, follow the tut above and please post your way.

a.) Go to Start>All programs>Accessories> and rt click cmd prompt, and run as administrator.

b.) Enter..minus quotes "bcdedit /set IncreaseUserVA 3072"

c.) Hit enter and reboot.

These following are a quick tip and a small explanation of this fix, thanks guys.

Quote:
Quote:
Originally Posted by silencerelite
I should mention this, for anyone who uses Business edition of Vista, you may won't find run program so just type cmd in search bar from start menu and type "bcdedit /set IncreaseUserVA 3072" and click enter. It should say "The operation completed successfully." Then restart. That will work for any editions actually.
Thanks silencerelite!

Quote:
Quote:
Originally Posted by ginfest
Windows "normally" uses 2GB (2048) as the "boundary" between how much virtual memory is avail to the OS and and apps (4GB in a 32-bit system)
To reset to default run "bcdedit /set IncreaseUserVA 2048" in Vista-in XP just remove the "/3GB" switch from the line in the "Boot.ini" file
Thanks ginfest!



This did it for me, hope it helps you.

Last edited by grey_1; 04-11-07 at 09:25 PM.
  Reply With Quote