View Single Post
Old 04-02-07, 05:35 PM   #1
Thetargos
Registered User
 
Join Date: Dec 2004
Posts: 52
Send a message via ICQ to Thetargos Send a message via AIM to Thetargos
Default Anisotropic filtering and Antialias problems with 9755 and FX5900

I have been having trouble not being able to activate AA/AF on my FX5900 card with the latest drivers.

Kernel is 2.6.20 FC6 stock.

Using AIGLX (as Option AIGLX True) in Xorg, other pertinent options being used in Xorg.conf are:

Code:
Section "Module"
        Load  "fbdevhw"
        Load  "record"
        Load  "freetype"
        Load  "type1"
        Load  "glx"
        Load  "dbe"
        Load  "extmod"
EndSection

Section "Device"
        Identifier  "Videocard0"
        Driver      "nvidia"
        Option      "NoFlip" "true"
        Option      "NoLogo" "true"
        Option      "NVAGP" "3"
        Option      "HwCursor" "true"
        Option      "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        Option      "metamodes" "1280x1024_75 +0+0"
        Option      "RenderAccel" "true"
        SubSection "Display"
                Viewport   0 0
                Depth     24
#             Modes    "1280x1024" "1280x960" "1115x864" "1024x768" "800x600" 
"640x480"
        EndSubSection
I don't seem able to enable AA/AF by either exporting the environment variables or by using the nvidia-settings program, I will try to see if AIGLX or other of the driver options is what is preventing this by means of editing and testing, but I hadn't modified my Xorg.conf file in quite a while, and AA/AF was working just fine with the 1.0-9746 driver. Any help is greatly appreciated.

Edit

Exporting the __GL_FSAA_MODE variables do seem to work, alas setting the AA options (as well as sync to VBlank and AF) in nvidia-settings does not.
Thetargos is offline   Reply With Quote