View Single Post
Old 04-15-07, 03:46 PM   #64
johnjay
Registered User
 
Join Date: Mar 2007
Posts: 1
Default Re: beryl black windows bug

After battling this issue for some time, my solution was to simply add the following to ~/.beryl-managerrc (rendering, rendering path and binding options are "Automatic"):

[beryl-settings]
...
no_gl_yield=true

Not sure if this is a solution that will work for others but it did for me. I would get the "black window" bug consistently after opening 2-3 instances of either Firefox, Thunderbird or KDevelop. The only way it I could actually view the content inside the buggy black windows would be to "resize" them to minimally small dimensions.

That said, with the above setting I've had 10 instances of Firefox (yes I know about tabs), Thunderbird with 2 compose message windows, audacious and several other GTK+/Qt-based applications open without any black windows coming up while maximized.

Some of my environment information:
  • Gentoo
  • beryl 0.2.1
  • 128MB 6600GT
  • nvidia-drivers 1.0.9755-r1

I'd be interested to receive feedback from others regarding this solution or whether it worked for them.
johnjay is offline