View Single Post
Old 05-16-03, 03:45 PM   #2
schotty
Registered User
 
Join Date: May 2003
Location: Milwaukee
Posts: 8
Send a message via ICQ to schotty Send a message via AIM to schotty Send a message via Yahoo to schotty
Default X and TV-Out

It has been brought to my attention that my firware doesnt allow for 2 outputs of any kind at the same time. So in that case I would like to use a second card. That makes one Geforce and one TNT to do my bidding ... or not.

I added in the info I gatherd from my release notes PDF from nVIDIA. What is odd though is that even though I plug in my values needed for the PCI bus, X doesnt pick up correctly my PCI stuff. Here is my lspci output, my XF warnings and errors (dont think there are any errors though) and my XF86Config.

Any ideas on what I am apparently missing?

lspci info:
Code:
[schotty@drunkenmaster schotty]$ lspci
00:00.0 Host bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133] (rev 03)
00:01.0 PCI bridge: VIA Technologies, Inc. VT8363/8365 [KT133/KM133 AGP]
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586/B/686A/B PIPC Bus Master
IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. USB (rev 16)
00:07.3 USB Controller: VIA Technologies, Inc. USB (rev 16)
00:07.4 Host bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:0d.0 USB Controller: NEC Corporation USB (rev 41)
00:0d.1 USB Controller: NEC Corporation USB (rev 41)
00:0d.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
00:11.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 08)
00:11.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 08)
00:12.0 VGA compatible controller: nVidia Corporation NV4 [RIVA TNT] (rev 03)
00:14.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)
01:00.0 VGA compatible controller: nVidia Corporation NV15DDR [GeForce2 Ti] (rev a4)
[schotty@drunkenmaster schotty]$
XLog
Code:
(--) PCI: (0:18:0) nVidia Corporation NV4 [RIVA TNT] rev 3, Mem @ 0xe2000000/24, 0xe3000000/24
(--) PCI:*(1:0:0) nVidia Corporation NV15DDR [GeForce2 Ti] rev 164, Mem @ 0xe0000000/24, 0xd8000000/27

...snipitty snip...

(WW) NVIDIA: No matching Device section for instance (BusID PCI:0:18:0) found

XF86Config
Code:
Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		0 "Screen0" 0 0
	InputDevice	"Mouse0" "CorePointer"
	InputDevice	"Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
	RgbPath      "/usr/X11R6/lib/X11/rgb"
	FontPath     "unix/:7100"
EndSection

Section "Module"
	Load  "dbe"
	Load  "extmod"
	Load  "fbdevhw"
	Load  "glx"
	Load  "record"
	Load  "freetype"
	Load  "type1"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "keyboard"
	Option	    "XkbRules" "xfree86"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "IMPS/2"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5"
	Option	    "Emulate3Buttons" "no"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "IBM P70"
	HorizSync    29.0 - 82.0
	VertRefresh  50.0 - 120.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier	"Videocard0"
	Driver		"nvidia"
	VendorName	"Videocard vendor"
	BoardName	"NVIDIA GeForce 2 GTS (generic)"
	BusID		"PCI:1:0:0"
	Screen		0
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     16
	SubSection "Display"
		Depth     24
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     16
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     15
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     8
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth     4
		Modes    "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "Monitor"
	Identifier	"Monitor1"
	VendorName	"Philips"
	ModelName 	"25PS40"
	HorizSync	30 - 50
	VertRefresh	60
	Option		"TVOutFormat"	"Composite"
	Option		"TVStandard"	"NTSC-M"
EndSection

Section "Device"
	Identifier	"Videocard1"
	Driver		"nvidia"
	VendorName	"Diamond"
	BoardName	"Viper v550"
	BusID		"PCI:0:12:0"
	Screen		1
EndSection

Section "Screen"
	Identifier "Screen1"
	Device     "Videocard1"
	Monitor    "Monitor1"
	DefaultDepth     16
	SubSection "Display"
		Depth     16
		Modes    "1024x768" "800x600" "640x480"
	EndSubSection
EndSection
schotty is offline   Reply With Quote