View Single Post
Old 04-19-07, 03:41 AM   #2
awx
Registered User
 
Join Date: Apr 2007
Posts: 5
Default Re: paravirt_ops in 2.6.21 support expected?

current 2.6.20 linux kernel in debian/unstable does not work because of this [driver v1.0-9755]:

Code:
[...]
     Building modules, stage 2.
   make -f /usr/src/linux-headers-2.6.20-1-k7/scripts/Makefile.modpost
     scripts/mod/modpost -m  -i /usr/src/linux-headers-2.6.20-1-k7/Module.symve
   rs -I /tmp/selfgz5622/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/Module.symve
   rs -o /tmp/selfgz5622/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/Module.symve
   rs -w  /tmp/selfgz5622/NVIDIA-Linux-x86-1.0-9755-pkg1/usr/src/nv/nvidia.o
   FATAL: modpost: GPL-incompatible module nvidia.ko uses GPL-only symbol 'para
   virt_ops'
*edit*
got it working using instructions from here: http://www.nvnews.net/vbulletin/showthread.php?t=87541
awx is offline   Reply With Quote