View Single Post
Old 04-19-07, 07:20 AM   #12
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: OpenGL problem 9746 driver

I'm using a GENERIC kernel, and here's my xorg.conf file:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Mon Oct 16 22:13:07 PDT 2006

Section "ServerLayout"
Identifier "Layout[all]"
Screen "Screen0" 0 0
InputDevice "Keyboard[0]" "CoreKeyboard"
InputDevice "Mouse[1]" "CorePointer"
Option "Clone" "off"
Option "Xinerama" "off"
EndSection

Section "Files"
FontPath "/usr/X11R6/lib/X11/fonts/misc/"
FontPath "/usr/X11R6/lib/X11/fonts/TTF/"
FontPath "/usr/X11R6/lib/X11/fonts/OTF"
FontPath "/usr/X11R6/lib/X11/fonts/Type1/"
FontPath "/usr/X11R6/lib/X11/fonts/CID/"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/"
FontPath "/usr/X11R6/lib/X11/fonts/decoratives"
FontPath "/usr/X11R6/lib/X11/fontsetype"
FontPath "/usr/X11R6/lib/X11/fontse1/gsfonts"
FontPath "/usr/X11R6/lib/X11/fontsetype/openoffice"
FontPath "/usr/X11R6/lib/X11/fontsetype/ttf-bitstream-vera"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "glx"
Load "type1"
Load "extmod"
Load "dbe"
Load "freetype"
Load "v4l"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "on"
EndSection

Section "InputDevice"
Identifier "Keyboard[0]"
Driver "kbd"
Option "Protocol" "Standard"
Option "XkbLayout" "us"
Option "XkbModel" "pc104"
Option "XkbRules" "xfree86"
EndSection

Section "InputDevice"
Identifier "Mouse[1]"
Driver "mouse"
Option "Buttons" "7"
Option "Device" "/dev/sysmouse"
Option "Name" "Belkin USB-PS2 Adapter"
Option "Protocol" "sysmouse"
Option "Vendor" "Sysp"
Option "ZAxisMapping" "4 5"
EndSection

Section "Modes"
Identifier "Modes[0]"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "VIEWSONIC"
ModelName "PF790"
UseModes "Modes[0]"
DisplaySize 305 230
Option "CalcAlgorithm" "XServerPool"
EndSection
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7900"
Option "AddARGBGLXVisuals" "true"
Option "MetaModes" "1280x1024,1280x1024; 1280x1024,NULL; 1152x864,1152x864, 1152x864,NULL; 1024x768,1024x768; 1024x768,NULL; 800x600,800x600; 800x600,NULL; 640x480,640x4
80; 640x480,NULL"
Option "SecondMonitorHorizSync" "30-85"
Option "SecondMonitorVertRefresh" "48-120"
Option "TwinViewOrientation" "RightOf"
Option "AddARGBGLXVisuals" "True"
Option "TwinView" "1"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "True"
EndSection
adamk75 is offline   Reply With Quote