View Single Post
Old 05-17-03, 03:43 PM   #1
Liontooth
GeForce4 420 Go 32M
 
Join Date: May 2003
Posts: 17
Default GLX fails on 4363

I've had the 4349 driver running fine for a few months on a laptop with a GeForce4 420 Go 32M. The new 4363 works too, but GLX fails to load:

(II) NVIDIA(0): AGP 4X successfully initialized
(II) NVIDIA(0): Setting mode "1600x1200,1280x854+0+1200"
(EE) NVIDIA(0): Failed to load GLX
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-GLX
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled

I'm now running XFree86 4.3.0 under Debian sid with the 2.4.20 kernel; log file attached.
If I start a 3D program, such as Tuxracer, X crashes.

Added: I downgraded to the 4349 driver and GLX now loads fine (I made no other changes):

(II) NVIDIA(0): AGP 4X successfully initialized
(II) NVIDIA(0): Setting mode "1600x1200,1280x854+0+1200"
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(**) Option "dpms"
(**) NVIDIA(0): DPMS enabled
(II) Loading extension NV-GLX
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled

(II) [GLX]: Initializing GLX extension

Tuxracer now works fine -- however, now I can't switch modes in XFree86 4.3.0. Since that matters more to me than 3D at the moment, I'll revert to the 4363 driver, hoping for a swift update to fix the GLX problem.

Cheers,
Liontooth
Attached Files
File Type: log xfree86.0.log (33.5 KB, 140 views)

Last edited by Liontooth; 05-17-03 at 04:06 PM.
Liontooth is offline   Reply With Quote