View Single Post
Old 08-28-02, 07:41 PM   #1
loudawg
Guest
 
Posts: n/a
Default Geforce 440 Go, SuSE 8.0, and new Nvidia drivers

Hello everyone. I just bought a Toshiba Satellite 5105-S701 laptop a couple nights ago and am trying to get SuSE running on it. Here's my problem. I install SuSE. It gets to the configuration section for X. I choose the option that says "Use 3d acceleration". It gives me that message saying that this is just at dummy driver and the real 3d driver needs to be downloaded via Yast2's online update. Ok, no problem I think. So I choose the VESA 1600x1200@60Hz display adapter, because it obviously was not able to detect this screen by itself. I think it only allowed me to choose up to 16bit color, which is fine for now. I click Test, and wow, it's working perfectly! I'm happy. So I finish the installation, go to online update, get the new drivers, and reboot. Screen flickers a few times, and X fails to load. It says that a screen was found, but there was no usuable configuration.

I've been playing with this thing all day trying to get it to work. With the new NVIDIA drivers, the highest settings that X will work in now is 1280x1024, 24bit color, which isn't all that bad, but the fonts suddenly are HUGE and plus I know this thing will handle the 1600x1200, and so that's what I want!!

I've tried getting the drivers off of Nvidia directly. I got the ones made for this distro, didn't work. I got the source files and rebuilt them, didn't work. The ONLY way this has worked so far is to use the "dummy" driver "nv". And at this point right now, Yast is only allowing me to use 8bit color at 1600x1200. I hate stupid GUIs sometimes. I know it'll handle 16bit color cause it just did it a few hours ago! And it's actually supposed to be able to handle 24bit.

I played around with xmode and putting that line in the XF86Config file but that didn't really seem to help. It'll either just not work, or it'll choose 1280x1024 instead.

Is there ANY way to force this thing to use the settings I KNOW it can handle? Thank you very very much for any help.

Louie
  Reply With Quote