View Single Post
Old 05-08-07, 06:06 PM   #178
Registered User
Join Date: May 2007
Posts: 1
Default Re: first display on twinview

I have a 19" 1280x1024 on the left and want it as my primary monitor, and have 15" 1024x768 on the other side of the room to the right.

I dont understand what more i can do. It still has errors constantly. I've used the nvidia settings manager to create the xorg.conf and then added in lines to make my DVI as primary monitor. Now it will startup fine, and login will be on the correct screen, and programs launch to the correct screen, but as soon as I try playing a video (several tried) it will open to the small screen and from then on all programs will open on the small screen until X is reset. Please help, heres my xorg:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder3) Mon Feb 26 23:39:38 PST 2007

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"

Section "Files"
RgbPath "/usr/lib/X11/rgb"

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"

Section "ServerFlags"
Option "Xinerama" "0"

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "AMT M1-150T"
HorizSync 30.0 - 62.0
VertRefresh 50.0 - 75.0
Option "DPMS"

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7900 GT/GTO"
Option "NoLogo"
# Option "TwinViewXineramaInfoOrder" "DFP-1,CRT-0"
Option "TwinViewXineramaInfoOrder" "DFP-1, CRT-0"
Option "UseDisplayDevice" "DFP-1, CRT-0"
Option "TwinViewOrientation" "DFP-1 LeftOf CRT-0"
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
Option "RenderAccel" "True"
Option "AllowGLXWithComposite" "True"
Option "backingstore" "True"
Option "TripleBuffer" "True"

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "metamodes" "CRT: 1024x768 +1280+0, DFP: 1280x1024 +0+0; CRT: 832x624 +1280+0, DFP: nvidia-auto-select +0+0; CRT: 800x600 +1280+0, DFP: nvidia-auto-select +0+0; CRT: 640x480 +1280+0, DFP: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
tic is offline   Reply With Quote