View Single Post
Old 05-19-03, 01:39 PM   #1
honghsu
Registered User
 
Join Date: Dec 2002
Posts: 12
Default startx hang forever when USB is plugged in

Hi,

I have Asus A7N266-VM/LAN/AA motherboard with nVIDIA GeForce2 integrated GPU; AMD Athlon XP 1600+ cpu and XFree86 4.2.0 on redhat Linux kernel 2.4.18-3.

The NVchooser.sh tells me to install
NVIDIA_kernel-1.0-2960.rh73up.athlon.rpm and NVIDIA_GLX_1.0-2960.i386.rpm
I did.

The X server works fine. However, every time the USB is plugged in, such as zip drive or camera, startx will always hang forever.

Could some experts point out where went wrong and how to find log. Thanks,
-Hong

following is XF86Config-4:
# XFree86 4.2.0 configuration generated by Xconfigurator 4.10.7

Section "ServerLayout"
Identifier "XFree86 Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

# Red Hat Linux 6.0 and later use the xfs font server for improved
# interactive performance

Section "Files"
FontPath "unix/:7100"
EndSection

# Module loading section

Section "Module"
Load "dbe" # Double-buffering
# Load "GLcore" # OpenGL support
# Load "dri" # Direct rendering infrastructure
Load "glx" # OpenGL X protocol interface
Load "extmod" # Misc. required extensions
Load "v4l" # Video4Linux
# Load "record" # X event recorder
# You only need the following two modules if you do not use xfs.
# Load "freetype" # TrueType font handler
# Load "type1" # Adobe Type 1 font handler
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
# Modified by mouseconfig
Driver "mouse"
Option "Device" "/dev/mouse"
Option "Protocol" "IMPS/2"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "NEC MultiSync XE17"
VendorName "NEC"
ModelName "MultiSync XE17"
HorizSync 31.0-65.0
VertRefresh 55.0-120.0
Option "dpms"
EndSection

Section "Device"
Identifier "NVIDIA GeForce 2 MX (generic)"
Driver "nvidia"
BoardName "NVIDIA 220D GeForce 2 Integrated GPU"
Option "NvAgp" "1"
EndSection

Section "Device"
Identifier "Linux Frame Buffer"
Driver "fbdev"
BoardName "Unknown"
EndSection

Section "Screen"
Identifier "Screen0"
Device "NVIDIA GeForce 2 MX (generic)"
Monitor "NEC MultiSync XE17"
DefaultDepth 24
Subsection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "DRI"
Mode 0666
EndSection
honghsu is offline   Reply With Quote