View Single Post
Old 05-20-03, 09:55 AM   #28
Registered User
Join Date: May 2003
Posts: 3

Success !! all I had to do was disable APIC in the bios as well as the other KT400 workarounds. It also fixed my soundcard. I wonder why they bothered putting APIC on a single processor mobo ?

This is the workaround I used :

Originally posted by Gyokuran

OK, I'll give some details on my successfull installation hoping that it will help. The following settings enable AGP 4x with the nvidia agp driver.

Gainward GeForce3 with VIA KT400

Linux kernel: 2.4.20, patched with newest acpi and bttv drivers. IMPORTANT: disable agpgart support in kernel (it only supports AGP x2 for KT400 and not good anyway)

NVIDIA driver version: 43.63

/etc/X11/XF86Config: (relevant parts)
Section "Module"
Load "dbe"
Load "type1"
Load "speedo"
Load "extmod"
Load "freetype"
Load "v4l"
Load "glx"
Section "Device"
Identifier "Device[0]"
Driver "nvidia"
BoardName "Gainward"
Option "dpms"
Screen 0
Option "NoLogo" "true"
Option "NvAgp" "1"
Option "PageFlip" "true"
Option "DigitalVibrance" "2"
Option "HWCursor" "true"
Option "SWCursor" "false"

alias char-major-195 nvidia
options nvidia NVreb_EnableVia4x=1
options nvidia NVreg_ReqAGPRate=0x4

image = /boot/kernel2420
label = linux-noacpi
root = /dev/hda7
append = " pci=noacpi pci=biosirq"
(do not forget to run lilo after changing lilo.conf)

Good luck.

end of posting by Gyokuran

Thanks Gyokuran, you really helped me out a lot

Last edited by Sestun; 05-22-03 at 02:52 PM.
Sestun is offline   Reply With Quote