View Single Post
Old 05-17-07, 07:29 PM   #1
go16
Registered User
 
Join Date: May 2007
Posts: 1
Default FBSD 6.1 & problems with AGP Geforce7300GT

Hi!

I'm using FreeBSD 6.1-RELEASE (i386), and my problem is related to enabling AGP for my Geforce 7300GT.

FreeBSD 6.1-RELEASE (i386)
Tornado Geforce 7300GT 256MB DDR2 AGP DVI+TV
SuperMicro P4SPA+
xorg-server-6.9.0_6

ports install
/usr/ports/x11/nvidia-driver or 9631 or 7194
/usr/ports/x11/nvidia-settings
/usr/ports/x11/nvidia-xconfig

/etc/rc.conf
linux_enable="YES"
compat5x_enable="YES"

/boot/loader.conf
hw.pci.allow_unsupported_io_range="1"
nvidia_load="YES"
linux_load="YES"

dmesg
kernel: pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
kernel: pci0: <ACPI PCI bus> on pcib0
kernel: agp0: <Intel 82865 host to AGP bridge> mem 0xd8000000-0xdfffffff at device 0.0 on pci0
kernel: pcib1: <PCI-PCI bridge> at device 1.0 on pci0
kernel: pci1: <PCI bus> on pcib1
kernel: pcib1: memory: end (cfffffff) < start (e0000000)
kernel: nvidia0: <GeForce 7300 GT> mem 0xe0000000-0xe0ffffff,0xc0000000-0xcfffffff,0xe1000000-0xe1ffffff irq 16 at device 0.0 on pci1
kernel: pcib1: memory: end (cfffffff) < start (e0000000)
kernel: nvidia0: NVRM: NVIDIA MEM resource alloc failed, BAR1 @ 0x14.
kernel: nvidia0: NVRM: NVIDIA hardware alloc failed.
kernel: device_attach: nvidia0 attach returned 6

startx
(II) Setting vga for screen 0.
(II) Setting vga for screen 1.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0): that the NVIDIA device files have been created properly.
(EE) NVIDIA(0): Please consult the NVIDIA README for details.
(EE) NVIDIA(0): *** Aborting ***
(**) NVIDIA(1): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(1): RGB weight 888
(==) NVIDIA(1): Default visual is TrueColor
(==) NVIDIA(1): Using gamma correction (1.0, 1.0, 1.0)
(EE) NVIDIA(1): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(1): that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(1): that the NVIDIA device files have been created properly.
(EE) NVIDIA(1): Please consult the NVIDIA README for details.
(EE) NVIDIA(1): *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "nvidia"
(EE) Screen(s) found, but none have a usable configuration.


Thank you.
go16 is offline   Reply With Quote