View Single Post
Old 05-21-07, 01:37 AM   #4
paulgress
Registered User
 
Join Date: Sep 2005
Posts: 38
Default Re: Screen stays black: MX-400 problem?

The reasons I stated acpi option can be found in "man eeprom"

"x86 Only
acpi-user-options

A configuration variable that controls the use of
Advanced Configuration and Power Interface (ACPI), a
power management specification. The acceptable values
for this variable depend on the release of the Solaris
operating system you are using.

For all releases of Solaris 10 and Solaris 11, a value
of of 0x0 means that there will be an attempt to use
ACPI if it is available on the system. A value of 0x2
disables the use of ACPI.

For the Solaris 10 1/06 release, a value of 0x8 means
that there will be an attempt to use ACPI in a mode com-
patible with previous releases of Solaris 10 if it is
available on the system. The default for Solaris 10 1/06
is 0x8.

For releases of Solaris 10 after the 1/06 release and
for Solaris 11, the default is 0x0.

Most users can safely accept the default value, which
enables ACPI if available. If issues related to the use
of ACPI are suspected on releases of Solaris after
Solaris 1/06, it is suggested to first try a value of
0x8 and then, if you do not obtain satisfactory results,
0x02."

The way to disable it booting from the cdrom is:

boot cdrom -B acpi-user-options=2

There is also an option to turn dma off for the cdrom drive:

atapi-cd-dma-enabled=0

The reason is sometimes these setting give problems upon booting and you stated early Solaris worked fine, this is one difference that affects booting.

Did you successfully install Solaris 10, or are you failing at the install process.
paulgress is offline   Reply With Quote