Thread: x11base change
View Single Post
Old 05-25-07, 01:20 AM   #2
Ernest
Registered User
 
Join Date: Apr 2007
Posts: 9
Default Re: x11base change

Quoting myself:

> Nvidia-driver in FreeBSD ports is already fixed and builds fine

...yeah, but haven't got it to work for four days, so now I am asking for help.

I can run X apps with the nv driver, but the nvidia-driver fails. I get always a segmentation error. Typescript [...comments...]:

# X -config xorg.conf.new [...using the nv driver...]
X Window System Version 7.2.0
Release Date: 22 January 2007
X Protocol Version 11, Revision 0, Release 7.2
Build Operating System: FreeBSD 6.2-STABLE i386
Current Operating System: FreeBSD asinusaureus 6.2-STABLE FreeBSD 6.2-STABLE #0: Thu May 24 11:20:28 CEST 2007 root@asinusaureus:/usr/obj/usr/src/sys/ZORN i386
Build Date: 21 May 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu May 24 11:56:19 2007
(++) Using config file: "/root/xorg.conf.new"
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

[...works fine; same if I launch the desktop...]

# X -config /etc/X11/xorg.conf [...now as configured with nvidia-xconfig...]
X Window System Version 7.2.0
Release Date: 22 January 2007
X Protocol Version 11, Revision 0, Release 7.2
Build Operating System: FreeBSD 6.2-STABLE i386
Current Operating System: FreeBSD asinusaureus 6.2-STABLE FreeBSD 6.2-STABLE #0: Thu May 24 11:20:28 CEST 2007 root@asinusaureus:/usr/obj/usr/src/sys/ZORN i386
Build Date: 21 May 2007
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Thu May 24 11:57:34 2007
(++) Using config file: "/etc/X11/xorg.conf"

[...shows the nvidia splash screen and then aborts...]

Fatal server error:
Caught signal 11. Server aborting

Abort (core dumped)

# tail /var/log/messages
[...]
May 24 11:57:37 asinusaureus kernel: pid 1840 (Xorg), uid 0: exited on signal 6 (core dumped)

No relevant info in xorg logs.

After much looking, I am still clueless. Any hint?
Ernest is offline   Reply With Quote