View Single Post
Old 05-26-07, 12:00 AM   #81
BrainRocketry
Registered User
 
Join Date: May 2007
Posts: 3
Default Re: 1080i Resolution unused by nvidia-auto-select on 60-inch HDTV, [ Sony KDS-R60XBR1

I'm having trouble getting my xorg config to work with my tv, right now the best I can get out of my monitor is 1280x720 and the borders of the screen are cut off. I'd really like to get it working in 1080i.

tv specs:
model: Sanyo DP32746 LCD TV (DP32746)
size:32" Diagonal
Aspect Ratio:16:9
native resolution: 1366x768
formats:480i, 480p, 720p, 1080i (scaling only works with xbox)
cable: dvi / hdmi

graphics card: Geforce 7600 gs
drivers: nvidia 1.0-9755
distro: Kubuntu
shoe size: 9.5

I tried krionius's config but it just goes back to 1280x720. I could live with the 720i if the edges weren't cut off. I'm a bit of a newb to linux and tv out config and i was wondering if someone could give me a hand. bellow is a repost of what I tried:
Code:
# **********************************************************************
# Monitor section
# **********************************************************************

Section "Monitor"
    Identifier  "Mon"
    HorizSync   31.5 - 57.0
    VertRefresh 50-80
EndSection

Section "Monitor"

    Identifier  "Mon1"
    HorizSync    15.0 - 46.0
    VertRefresh  49.0 - 61.0
    ModeLine "1920x1080" 74.250 1920 2008 2052 2200 1080 1084 1094 1125 interlace +hsync +vsync
#    Option    "DPMS"
EndSection


# **********************************************************************
# Graphics device section
# **********************************************************************

# Any number of graphics device sections may be present


# Device configured by xorgconfig:

Section "Device"
    Identifier                          "NV1"
    Driver                              "nvidia"
    Option "AddARGBGLXVisuals" "True"
    Option "DisableGLXRootClipping" "true"
    BusID "PCI:5:0:0"
    Screen 0
EndSection

Section "Device"
    Identifier                          "NV2"
    Driver                              "nvidia"
    Option "AddARGBGLXVisuals" "True"
    Option "DisableGLXRootClipping" "true"

        Option "NoVertRefreshCheck"
        Option  "ModeValidation" "NoVertRefreshCheck,NoDFPNativeResolutionCheck,NoEdidMaxPClkCheck,NoHorizSyncCheck,NoMaxPClkCheck"
        Option "UseEDIDDpi" "false"
        Option "ExactModeTimingsDVI" "true"
        Option "FlatPanelProperties" "Scaling=Native"

#        Option  "NoPredefinedModes"
#        Option  "DPI" "120x120"
#        Option "NoDDC" "TRUE" 
#        Option    "UseEDID" "FALSE"

    BusID "PCI:5:0:0"
    Screen 1
EndSection


# **********************************************************************
# Screen sections
# **********************************************************************

Section "Screen"
    Identifier  "Screen0"
    Device      "NV1"
    Monitor     "Mon"
    DefaultDepth 24
    #Option "backingstore"

    Subsection "Display"
        Depth       24
        Modes       "1280x1024" "1024x768" "800x600" "640x480"
        ViewPort    0 0  # initial origin if mode is smaller than desktop
    EndSubsection
EndSection

Section "Screen"
    Identifier  "Screen1"
    Device      "NV2"
    Monitor     "Mon1"
    DefaultDepth 24

    Subsection "Display"
        Depth       24
#       Modes "1240x720"
        Modes "1920x1080_60i"
        # "1280x720" "640x480"
        ViewPort    0 0  # initial origin if mode is smaller than desktop
    EndSubsection
EndSection


# **********************************************************************
# ServerLayout sections.
# **********************************************************************

# sans serverLayout section
Attached Files
File Type: log nvidia-bug-report.log (92.7 KB, 96 views)
BrainRocketry is offline   Reply With Quote