Thread: Cannot start X
View Single Post
Old 05-26-07, 12:49 PM   #1
ntamp
Registered User
 
Join Date: Jan 2006
Posts: 7
Default Cannot start X

Hello,
I use FreeBSD 6.2 and Xorg 7.2 (card` s chipset is Nvidia 440MX)
I installed latest nvidia drivers from ports, but i cannot start X.
An error appeared:

(II) Module kbd: vendor="X.Org Foundation"
compiled for 7.2.0, module version = 1.1.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.7
(II) NVIDIA dlloader X Driver 1.0-9746 Tue Dec 19 13:23:45 PST 2006
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 01:00:0
(WW) NVIDIA(0): The NVIDIA GeForce4 MX 440 GPU installed in this system is
(WW) NVIDIA(0): supported through the NVIDIA 1.0-96xx Legacy drivers.
(WW) NVIDIA(0): Please visit http://www.nvidia.com/object/unix.html for
(WW) NVIDIA(0): more information. The 1.0-9746 NVIDIA driver will ignore
(WW) NVIDIA(0): this GPU. Continuing probe...
(EE) No devices detected.

Fatal server error:
no screens found


Then i installed nvidia-driver-9631 and then nvidia-driver-7184 and the result is:

(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(II) XINPUT: Adding extended input device "NVIDIA Damage Notification Manager" (type: Other)
(II) XINPUT: Adding extended input device "NVIDIA Kernel RC Handler" (type: Other)
(II) XINPUT: Adding extended input device "NVIDIA Event Handler" (type: Other)
(II) Mouse1: SetupAuto: hw.iftype is 4, hw.model is 0
(II) Mouse1: SetupAuto: protocol is SysMouse

Caught signal 10. Server aborting

Thank you

Xorg:
Code:
Section "ServerLayout"
    Identifier     "Simple Layout"
    Screen         "Screen 1" 0 0
    InputDevice    "Mouse1" "CorePointer"
    InputDevice    "Keyboard1" "CoreKeyboard"
EndSection

Section "Files"
    FontPath        "/usr/local/lib/X11/fonts/misc/"
    FontPath        "/usr/local/lib/X11/fonts/TTF/"
    FontPath        "/usr/local/lib/X11/fonts/OTF"
    FontPath        "/usr/local/lib/X11/fonts/Type1/"
    FontPath        "/usr/local/lib/X11/fonts/100dpi/"
    FontPath        "/usr/local/lib/X11/fonts/75dpi/"
    FontPath        "/usr/local/lib/X11/fonts/local/"
    FontPath        "/usr/local/lib/X11/fonts/TrueType/"
EndSection

Section "Module"
    Load           "dbe"        # Double buffer extension
    SubSection     "extmod"
        Option         "omit xfree86-dga"   # don't initialise the DGA extension
    EndSubSection
    Load           "freetype"
    Load           "glx"
EndSection

Section "InputDevice"
    Identifier     "Keyboard1"
    Driver         "kbd"
    Option         "AutoRepeat" "500 30"
    Option         "XkbRules" "xorg"
    Option         "XkbModel" "pc101"
    Option         "XkbLayout" "us,el"
    Option         "XkbOptions" "grp:alt_shift_toggle"
EndSection

Section "InputDevice"
    Identifier     "Mouse1"
    Driver         "mouse"
    Option         "Protocol" "Auto"    # Auto detect
    Option         "Device" "/dev/sysmouse"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier     "philips"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 76.0
EndSection

Section "Device"

    #VideoRam    65536
    Identifier     "gforce"
    Driver         "nvidia"
EndSection

Section "Screen"
    Identifier     "Screen 1"
    Device         "gforce"
    Monitor        "philips"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
        Modes      "1280x1024"
    EndSubSection
EndSection
ntamp is offline   Reply With Quote