View Single Post
Old 05-29-07, 03:20 PM   #1
Soulstealer
FreeBSD Rules the World
 
Soulstealer's Avatar
 
Join Date: May 2007
Location: Necropolis
Posts: 7
Send a message via ICQ to Soulstealer
Default The "NVRM: Xid ..." problem

Hello nVidia
I've noticed that many linux users have a similar problem
so my problem is:
when I run quake3 it freezes in the first few seconds in the gameplay
it stands frozen for 10-20 seconds and gets unfrozen for 1-2 seconds and than again freezes for 10-20 seconds and again unfreezes for 1-2 seconds and this repeats forever
but it never crashes (it's FreeBSD of course, not linux )
anyway when I quit the game I can see the fallowing in /usr/log/messages

May 29 19:29:14 e-soul kernel: NVRM: Xid (0001:00): 30, L1 -> L0
May 29 19:29:30 e-soul kernel: NVRM: Xid (0001:00): 8, Channel 00000002
May 29 19:29:30 e-soul kernel: NVRM: Xid (0001:00): 30, L1 -> L0
May 29 19:29:53 e-soul kernel: NVRM: Xid (0001:00): 8, Channel 00000002
May 29 19:29:53 e-soul kernel: NVRM: Xid (0001:00): 30, L1 -> L0
May 29 19:30:16 e-soul kernel: NVRM: Xid (0001:00): 8, Channel 00000002
May 29 19:30:16 e-soul kernel: NVRM: Xid (0001:00): 30, L1 -> L0
May 29 19:30:40 e-soul kernel: NVRM: Xid (0001:00): 8, Channel 00000002
May 29 19:30:40 e-soul kernel: NVRM: Xid (0001:00): 30, L1 -> L0

this makes me MAD because I love to play quake3
so I had the same problem before 1-2 months...
let me start from the begining...
I've installed FreeBSD somewhen...and installed nvidia-driver too and everything was fine and was playing quake3 without any problems
but when the new version of gettext apeared I had to upgrade most of my packages and after upgradeing them this problem apeared...
I've tried many things to solve it but with no success including removing of all xorg related packages and compiling them again
the last chance was to reinstall FreeBSD
so I did it
and after clean install it worked
the problem was gone...
but now I've upgraded to xorg 7.2 and this problem apeared again!

my hardware is:
motherboard: ASUS P4P800SE
videocard: GF FX5500

my software is:
FreeBSD-6.2-STABLE
xorg 7.2
latest nvidia-driver from ports

does anyone know what is this problem caused from ?
thank you
Soulstealer is offline   Reply With Quote