View Single Post
Old 05-23-03, 12:14 PM   #1
Arach
Registered User
 
Join Date: May 2003
Posts: 17
Post Performance Problems (redux?)

ok, once again I'm battling performance troubles, as many others here have been doing without any conclusive results.

Could someone direct me to things to test or that would work here, please?


glxgears performance (Default, 25bpp)
3588 frames in 5.0 seconds = 717.600 FPS
3581 frames in 5.0 seconds = 716.200 FPS
3593 frames in 5.0 seconds = 718.600 FPS
3597 frames in 5.0 seconds = 719.400 FPS



I'll try to be thorough here in my bugreporting.



Hardware details:
MSI GeForce4 MX440
Asus a7v8X-X: via kt400 chipset
Athlon T-bird 1400
Winbond DDR3200 Ram.

Software:
Gentoo Linux (1.4 base)
Xfree 4.3
glibc 2.3.2
nvidia : 4363
kernel :2.4.21-pre5-aa2 (this adds agp 2.0 support for kt400 boards)



Settings:
APIC (UP-APIC) is disabled in the kernel.


/proc/driver/nvidia/agp/status
Status: Enabled
Driver: AGPGART
AGP Rate: 4x
Fast Writes: Enabled
SBA: Disabled

/proc/driver/nvidia/cards/0
Model: GeForce4 MX 440
IRQ: 11
Video BIOS: 04.17.00.45.91
Card Type: AGP

bitdepth 24/32 bpp

installation:
ldd `which glxgears` |grep GL
libGL.so.1 => /usr/lib/libGL.so.1 (0x40028000)
libGLcore.so.1 => /usr/lib/libGLcore.so.1 (0x40314000)


lrwxrwxrwx 1 root root 48 2003-05-21 18:28 /usr/lib/libGLcore.so.1 -> /usr/lib/opengl/nvidia/lib/libGLcore.so.1.0.4363
lrwxrwxrwx 1 root root 44 2003-05-21 18:28 /usr/lib/libGL.so.1 -> /usr/lib/opengl/nvidia/lib/libGL.so.1.0.4363

Cut from lspci -vv :
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400 AGP] Host Bridge
Subsystem: Asustek Computer, Inc.: Unknown device 807f
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz+ UDF- FastB2B- ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort+ >SERR- <PERR-
Latency: 0
Region 0: Memory at f0000000 (32-bit, prefetchable) [size=128M]
Capabilities: [a0] AGP version 2.0
Status: RQ=31 SBA+ 64bit- FW+ Rate=x1,x2,x4
Command: RQ=31 SBA- AGP+ 64bit- FW+ Rate=x4
Capabilities: [c0] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-


01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 440] (rev a3) (prog-if 00 [VGA])
Subsystem: Micro-Star International Co., Ltd.: Unknown device 8470
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B-
Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR-
Latency: 248 (1250ns min, 250ns max)
Interrupt: pin A routed to IRQ 11
Region 0: Memory at e6000000 (32-bit, non-prefetchable) [size=16M]
Region 1: Memory at e8000000 (32-bit, prefetchable) [size=128M]
Region 2: Memory at e7800000 (32-bit, prefetchable) [size=512K]
Expansion ROM at e77e0000 [disabled] [size=128K]
Capabilities: [60] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [44] AGP version 2.0
Status: RQ=31 SBA- 64bit- FW+ Rate=x1,x2,x4
Command: RQ=31 SBA- AGP+ 64bit- FW+ Rate=x4

cat /proc/mtrr
reg00: base=0x00000000 ( 0MB), size= 512MB: write-back, count=1
reg01: base=0xe8000000 (3712MB), size= 128MB: write-combining, count=1
reg02: base=0xe7800000 (3704MB), size= 512KB: write-combining, count=1
reg07: base=0xf0000000 (3840MB), size= 128MB: write-combining, count=1


Snip from dmesg:
0: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4363 Sat Apr 19 17:46:46 PDT 2003
Linux agpgart interface v0.99 (c) Jeff Hartmann
agpgart: Maximum main memory to use for agp memory: 439M
agpgart: Detected Via Apollo Pro KT400 chipset
agpgart: AGP aperture is 128M @ 0xf0000000
Arach is offline   Reply With Quote