View Single Post
Old 06-09-07, 04:32 PM   #1
jesso
Registered User
 
Join Date: Nov 2006
Posts: 38
Default nvidia / X reports wrong display size

I have a 1440x900 19" widescreen monitor.

When I do

Code:
xdpyinfo | grep dimensions
I get dimensions : 381x301 mm

when It should be 411x263 millimeters.

when I play a 4:3 aspect dvd with xine it is stretched.

Seems that even when I specify in xorg.conf the right displaySize, it gets ignored.

So is this an X server problem , or an nVidia driver problem?

I have the latest nvidia drivers and 7100 GS card.

Code:
Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Proview"
        DisplaySize  411 263
        HorizSync    30.0 - 80.0
        VertRefresh  60.0 - 75.0
        Option       "DPMS"
EndSection

Section "Device"
        Identifier  "Card0"
        Driver      "nvidia"
        VendorName  "nVidia Corporation"
        BoardName   "GeForce 7100 GS"
        BusID       "PCI:1:0:0"
        Option      "DPMS" "TRUE"
        Option      "UseEvents"         "false"
        Option      "RenderAccel"       "true"
        Option      "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
        Identifier   "Screen0"
        Device       "Card0"
        Monitor      "Monitor0"
        DefaultDepth 24
        Option       "metamodes" "1440x900_75 +0+0; 1440x900 +0+0"
        SubSection "Display"
                Depth 24
                Modes "1440x900"
        EndSubSection
EndSection

Section "Extensions"
        Option      "Composite"   "enable"
EndSection
jesso is offline   Reply With Quote