View Single Post
Old 05-23-03, 06:38 PM   #24
Humus
Coder
 
Humus's Avatar
 
Join Date: Aug 2002
Location: Toronto, Canada
Posts: 135
Send a message via ICQ to Humus
Default

Well, Doom III. Yes, it's OpenGL, but it's using ps2.0 equivalent on capable cards, GL_ARB_fragment_program and GL_NV_fragment_program.

When it comes to 1.x vs 2.0, well, if you have a choice you will probably always choose the one with wider compability so long as there's no significant performance difference. However, if you're desiding to use some cool techniques you're most likely forced to use 2.0 anyway, or scrap the idea all together.

Yes, games is always a step behind, but that doesn't make ps2.0 tests invalid. If nothing else there's always techdemos available on my site to take advantage of it.
__________________
Visit my site for cool demos
Humus is offline