View Single Post
Old 06-25-07, 06:37 PM   #1
westis
Registered User
 
Join Date: Jun 2007
Posts: 7
Default Bad picture quality on TV-out with nVidia GeForce 7200 GS

Hi,

I have installed an nVidia GeForce 7200 GS on a machine with Ubuntu Feisty. Installed the drivers with Envy.

I have connected to a TV through S-video and unfortunately with an adapter to composite and then to RCA, which is the connection to the TV (actually to the switch sending the vide & audio to the broadcasting central).

But those adapters work fine from an mpeg-2 card on the same computer, which gives excellent picture quality.

Because the issue here is that the picture quality on the TV is not at all pleasing. It's not sharp and even a bit jittery with much movement in the picture, like rolling titles. The picture is not even covering the entire width, but there are black borders to the left and right of the picture (PAL).

What can it be, as I do get picture and it is colour... ?

Here's the relevant part of the xorg.conf file:

Code:
Section "Monitor"
    Identifier     "Monitor[0]"
    HorizSync       31.5 - 82.0
    VertRefresh     50.0 - 90.0
EndSection

Section "Device"
    Identifier "Device[0]"
    Driver "nvidia"
    Option "TwinView"
    Option "SecondMonitorHorizSync"   	"30-50"
    Option "SecondMonitorVertRefresh" 	"60"
    Option "TwinViewOrientation"      	"Clone"
    Option "MetaModes" "1280x1024,1280,1024; 1024x768,1024x768; 800x600,800x600"
    #Option "MetaModes" "800x600,800x600"
    #Option "MetaModes" "800x600,720x576"
    Option "TVOutFormat" "SVIDEO"
    #Option "TVOutFormat" "COMPOSITE"
    Option "TVStandard" "PAL-B"
    Option "ConnectedMonitor" "CRT,TV"
    BusID  "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier     "Screen[0]"
    Device         "Device[0]"
    Monitor        "Monitor[0]"
    DefaultDepth    24
    SubSection     "Display"
        Viewport    0 0
        Depth       8
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
        Modes      "1280x1024" "1024x768" "800x600" "640x480"
    EndSubSection
EndSection
Would be very grateful for any assistance as this is for a local public access TV station that very much would like to use Linux as the base for a broadcasting system! Tried an ATI card first, but heard nVidia is better with TV-out. Please help me to prove that right.

/Daniel
westis is offline   Reply With Quote