View Single Post
Old 05-26-03, 04:43 AM   #1
M0ffe
Registered User
 
Join Date: May 2003
Location: Denmark
Posts: 2
Default Freeze on X shutdown or change to console

Hi

Another one of the infamous switch-to-console freezes.

When the nvidia drivers are installed, the machine freezes on a change to console or X shutdown. Complete freeze - nothing except a hard reboot works. This _only_ happens with TV-out enabled; if I disable TV-out everything works fine.

I just rolled back the drivers to 3123 - now everything works again - newer versions, no-go.

This is a Palit Daytona GF4 Ti4200 AGP8X. I am running Debian Sid (Woody also tried, same problems).

Status:

moffe@grignard:/proc/driver/nvidia# cat cards/0
Model: NV28
IRQ: 11
Video BIOS: 04.28.80.16.00
Card Type: AGP
moffe@grignard:/proc/driver/nvidia# cat agp/card
Fast Writes: Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000217:0x1f000104
moffe@grignard:/proc/driver/nvidia# cat agp/host-bridge
Host Bridge: Via Apollo Pro KT133
Fast Writes: Not Supported
SBA: Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000207:0x00000104
moffe@grignard:/proc/driver/nvidia# cat agp/status
Status: Enabled
Driver: AGPGART
AGP Rate: 4x
Fast Writes: Disabled
SBA: Disabled

This is a Thunderbird/1200 on a Asus A7V133-C (KT133A-based - BIOS 1009, PCB 1.05).

I am running 2.4.21-rc3 - the same trouble happens on 2.4.19 and 2.4.20. I have tried disabling ACPI and APIC (normally enabled); I am not using APM or nvidia-framebuffer. No changes in the kernel configuration helps.

I have tried almost anything related to AGP or PCI settings in the BIOS; no go. No IRQ sharing is taking place with the graphics card.

Attached is the XFree86.0.log.

Regards
/Rasmus
M0ffe is offline   Reply With Quote