View Single Post
Old 05-26-03, 04:32 PM   #3
philip_sigke
Registered User
 
Join Date: Feb 2003
Posts: 5
Default

thanks for your answer!

Quote:
Originally posted by leibold
Several things:
<Most importantly, you can't just enable DMA without specifying which DMA mode you want to use. Therefore the '-d 1' has to be always accompanied by an appropriate '-X mode' option. For UDMA the mode value to use is 64 + UDMA# (for older multiword DMA the constant is 32). >
you're right, i didn't write it correctly

< Some people report success with hdparm -c1 -d1 -X69 for 32-bit UDMA mode 5, but I'm following a more conservative recommendation to avoid the SATA data corruption issues:>
i know about that but i'm not the lucky one

<I'm reducing the transfer size to 15KB: echo "max_kb_per_request:15" > /proc/ide/hde/settings and use hdparm -d1 -X66 for UDMA mode 2. Since I don't know if -c1 or -c3 are save, I leave data transfers to be 16-bit.>
i found this today and i get just 22mb/sec :-( that would be better with pata hd
i've to admit that i'm quite unhappy with this mobo (actually with nvidia and they support for linux). i'd say that we all have to work and i've been spending alredy days just with this mobo. it's like ten years back with this kind of support

<If you want to see the maximum performance possible you could even try -X70 for UDMA mode 6, but I have no idea whether it will work.>
thank you for you help! really.
philip
philip_sigke is offline   Reply With Quote