View Single Post
Old 06-29-07, 01:45 AM   #1
kaptajnen
Registered User
 
Join Date: Jun 2007
Posts: 3
Default Low resolution on asus with 8400M G and openSUSE 10.2

Can't change the resolution. I have installed the latest NVIDIA driver for x86 on my asus A8Sc labtop with GeForce 8400M G graphic card and running SUSE 10.2. The system now list the card and the driver in sax2. If I then try to change resolution though Yast (graphics setup) and test the setup I get gray or blue screen and no respons. If I just click save nothing happens.

NVIDIA driver: NVIDIA-Linux-x86-100.14.09-pkg1.run


xorg.conf: I have manually added - Option "ModeValidation" "NoDFPNativeResolutionCheck"

Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder3)  Sat May 26 01:04:16 PDT 2007

# /.../
# SaX generated X11 config file
# Created on: 2007-06-28T13:32:54+0200.
#
# Version: 8.1
# Contact: Marcus Schaefer <sax@suse.de>, 2005
# Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
#
# Automatically generated by [SaX2] (8.1)
# PLEASE DO NOT EDIT THIS FILE!
#

Section "ServerLayout"
    Identifier     "Layout[all]"
    Screen         "Screen[0]" 0 0
    InputDevice    "Keyboard[0]" "CoreKeyboard"
    InputDevice    "Mouse[1]" "CorePointer"
    InputDevice    "Mouse[3]" "SendCoreEvents"
EndSection

Section "Files"
    InputDevices      "/dev/gpmdata"
    InputDevices      "/dev/input/mice"
    FontPath        "/usr/share/fonts/misc:unscaled"
    FontPath        "/usr/share/fonts/local"
    FontPath        "/usr/share/fonts/75dpi:unscaled"
    FontPath        "/usr/share/fonts/100dpi:unscaled"
    FontPath        "/usr/share/fonts/Type1"
    FontPath        "/usr/share/fonts/URW"
    FontPath        "/usr/share/fonts/Speedo"
    FontPath        "/usr/share/fonts/PEX"
    FontPath        "/usr/share/fonts/cyrillic"
    FontPath        "/usr/share/fonts/latin2/misc:unscaled"
    FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
    FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
    FontPath        "/usr/share/fonts/latin2/Type1"
    FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
    FontPath        "/usr/share/fonts/baekmuk:unscaled"
    FontPath        "/usr/share/fonts/japanese:unscaled"
    FontPath        "/usr/share/fonts/kwintv"
    FontPath        "/usr/share/fonts/truetype"
    FontPath        "/usr/share/fonts/uni:unscaled"
    FontPath        "/usr/share/fonts/CID"
    FontPath        "/usr/share/fonts/ucs/misc:unscaled"
    FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
    FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/misc:unscaled"
    FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
    FontPath        "/usr/share/fonts/hellas/Type1"
    FontPath        "/usr/share/fonts/misc/sgi:unscaled"
    FontPath        "/usr/share/fonts/xtest"
    FontPath        "/opt/kde3/share/fonts"
    FontPath        "unix/:7100"
EndSection

Section "Module"
    Load           "dbe"
    Load           "type1"
    Load           "freetype"
    Load           "extmod"
    Load           "glx"
    Load           "v4l"
EndSection

Section "ServerFlags"
    Option         "AllowMouseOpenFail" "on"
EndSection

Section "InputDevice"
    Identifier     "Keyboard[0]"
    Driver         "kbd"
    Option         "Protocol" "Standard"
    Option         "XkbLayout" "dk"
    Option         "XkbModel" "pc104"
    Option         "XkbRules" "xfree86"
EndSection

Section "InputDevice"
    Identifier     "Mouse[1]"
    Driver         "mouse"
    Option         "Buttons" "12"
    Option         "Device" "/dev/input/mice"
    Option         "Name" "Logitech USB Optical Mouse"
    Option         "Protocol" "explorerps/2"
    Option         "Vendor" "Sysp"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    Identifier     "Mouse[3]"
    Driver         "synaptics"
    Option         "Buttons" "5"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "on"
    Option         "HorizScrollDelta" "0"
    Option         "InputFashion" "Mouse"
    Option         "Name" "Synaptics;Touchpad"
    Option         "Protocol" "explorerps/2"
    Option         "SHMConfig" "on"
    Option         "Vendor" "Sysp"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "Modes"
    Identifier         "Modes[0]"
    ModeLine     "800x600" 38.3 800 832 928 1024 600 604 608 624 -hsync -vsync
EndSection

Section "Monitor"
    Identifier     "Monitor[0]"
    VendorName     "--> LCD"
    ModelName      "800X600@60HZ"
    UseModes       "Modes[0]"
    HorizSync       30.0 - 38.0
    VertRefresh     30.0 - 61.0
    Option         "CalcAlgorithm" "XServerPool"
    Option         "DPMS"
    Option "ModeValidation" "NoDFPNativeResolutionCheck"
EndSection

Section "Device"
    Identifier     "Device[0]"
    Driver         "nvidia"
    VendorName     "NVIDIA"
    BoardName      "GeForce 8400M G"
EndSection

Section "Screen"
    Identifier     "Screen[0]"
    Device         "Device[0]"
    Monitor        "Monitor[0]"
    DefaultDepth    24
    SubSection     "Display"
        Depth       15
        Modes      "800x600"
    EndSubSection
    SubSection     "Display"
        Depth       16
        Modes      "800x600"
    EndSubSection
    SubSection     "Display"
        Depth       24
        Modes      "800x600"
    EndSubSection
    SubSection     "Display"
        Depth       8
        Modes      "800x600"
    EndSubSection
EndSection

I hope someone have seen this problem before.

Kaptajnen
kaptajnen is offline   Reply With Quote