View Single Post
Old 07-08-07, 09:47 AM   #38
octaedro7
Registered User
 
octaedro7's Avatar
 
Join Date: Jul 2007
Posts: 1
Angry Re: is nForce MCP61 supported in Linux?

No matter what I try I cannot record from mic
I'm running Ubuntu Studio feisty (2.6.20-16-lowlatency) over an asrock alivenf6g -dvi (MCP61)
Code:
~$ hwinfo --sound
16: PCI 05.0: 0403 Audio device                                 
  [Created at pci.281]
  UDI: /org/freedesktop/Hal/devices/pci_10de_3f0
  Unique ID: CvwD.NrGvVZjpct4
  SysFS ID: /devices/pci0000:00/0000:00:05.0
  SysFS BusID: 0000:00:05.0
  Hardware Class: sound
  Model: "ASRock In Audio device"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x03f0 
  SubVendor: pci 0x1849 "ASRock Incorporation"
  SubDevice: pci 0x0888 
  Revision: 0xa2
  Driver: "HDA Intel"
  Driver Modules: "snd_hda_intel"
  Memory Range: 0xddef8000-0xddefbfff (rw,non-prefetchable)
  IRQ: 17 (153109 events)
  Module Alias: "pci:v000010DEd000003F0sv00001849sd00000888bc04sc03i00"
  Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
Code:
~$ lspci
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a2)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
02:00.0 VGA compatible controller: nVidia Corporation G70 [GeForce 7600 GT] (rev a1)
I' m really pissed off with all this, it's been over a month trying different things with same result. As you can see I'm using module snd_hda_intel as advised on nvidia's site with no avail. I've upgraded to alsa drivers 1.0.14-1 and nothing. Btw, this is not an Ubuntu studio issue, I have the exact problem on kubuntu feisty (2.6.20-16-generic)
on the same hardware.
Admins: Is MCP61 hda audio really supported for linux?
Is someone out there who have succeded in recording audio with this integrated soundcard?
__________________
AMD Athlon 64 X2 3800+
Asrock Alivenf6g DVI (MCP61)
2048 mb Ram DDR2 667 MHz
XFX Geforce 7600 GT 256 mb DDR3
250 Gb SATA2 Hitachi 7200 rpm
320 Gb eSATA2 Seagate 7200 rpm
Wifi USB SIS163u
DVD-RW Samsung 18x
TFT 19" 1440x900@75 Hanns G
octaedro7 is offline   Reply With Quote