View Single Post
Old 07-09-07, 06:31 AM   #5
Tub
Registered User
 
Join Date: Nov 2006
Posts: 95
Default Re: Problems with twinview and opengl games

I've had exactly the same problem way over a year ago when starting neverwinter nights fullscreen. There was at least one larger thread about the issue back then, maybe you can still dig it out.

What solved the problem for me was switching the displays: primary monitor on the left, secondary on the right using RightOf.

You could try using the 'UseDisplayDevice' option to redefine your primary screen - I never tested that though, since that option wasn't available back then. Consult the manual and try.

I suspect the problem might be solved by manually switching to a single-screen-resolution before starting the game (or writing a small script to do so), but actually I never tried that.


Right now I'm always spawning a second X server for games, to prevent game crashes/lockups from killing my workspace. Spawning a second X server that's configured without TwinView is another viable option. Basically you put a second xorg_game.conf into /etc/X11/, then create a small script that starts the game, copy or link it to ~/.xinitrc, then run
XORGCONFIG=xorg_game.conf startx -- :1
Don't forget to remove the ~/.xinitrc afterwards, or the next day you'll be booting straight into quake 3 instead of your desktop environment

Good luck.
Tub is offline   Reply With Quote