View Single Post
Old 05-27-03, 06:18 PM   #2
bwkaz
Registered User
 
Join Date: Sep 2002
Posts: 2,262
Default

Not sure if this stuff will help or not, but try to get rid of the pex5, vbe, xie, int10, and record modules (comment their Load lines in the Modules section). Most people don't need any of those -- but if commenting them allows you to startx successfully, then try adding them back in one at a time to see which one makes it fail.

There's another warning further down about "unable to change MTRR settings", but that's probably not relevant -- MTRR's can help performance, but I don't think I've ever seen them cause the error below.

The error is "failed to allocate a shared memory identifier". Couple of possible reasons for that one -- first, is /dev/shm mounted? Look in that directory, and if there aren't any files there, try mount -t tmpfs devshm /dev/shm as root, and see if that helps at all. If you don't have a /dev/shm directory, mkdir /dev/shm as root before you do the mount.

If mount complains about "no such filesystem tmpfs", then which distro and version are you running? You might have to recompile a kernel to enable shared memory.

If /dev/shm already has files in it, though, then don't bother with the mount command -- something else is wrong.

The actual failure is a segfault inside X itself, but I'm thinking that that's caused by not having a shared memory identifier.
__________________
Registered Linux User #219692
bwkaz is offline   Reply With Quote