View Single Post
Old 07-20-07, 10:14 PM   #1
fwelland
Registered User
 
Join Date: Jun 2007
Posts: 10
Default FWIW: HackTo to have gnome-sensors display nvidia GPU

For no real/important reason I wanted to have gnome-sensors display GPU temps.

After fumbling around a bit this worked for me (on this environment):

Fedora 7 (with most if not all up to date yum packages installed)
kernel 2.6.21-1.3228.fc7
NVidia 1.0-9762 driver install from .run package
Most if not all X.org devel packages

Steps:
  • Get nvidia settings 1.0 source code
  • Ignore the directions in the nvidia-settings-1.0/src/libXNVCtrl and read this thread http://www.nvnews.net/vbulletin/showthread.php?t=95244 to build the .a file.
  • After you have built libXNVCtrl.a; copy that to /usr/lib/local and copy nvidia-settings-1.0/src/libXNVCtrl/*.h to /usr/local/include/NVCtrl (make NVCtrl as needed)
  • get source code for sensors-applet-1.8.1
  • configure sensors applet build with something like this: ./configure --prefix=/usr --with-nvidia --libdir=/usr/local --includedir=/usr/local
  • run make for sensors applet
  • have sensors applet already installed via distro tools -- so that 'Add to Panel' knows about the sensors-applet
  • run 'make install' to install the sensors applet you built -- overwriting the existing one. (it will likely install into /usr/libexec)
  • now add to panel and configure as needed

There are probably more 'proper' ways to do this --- but the above worked for me. Feel free to clue me on better methods. Have fun!

(Now can anybody tell me how to get other sensors to work on a dell latitude d820? Is the ACPI CPU reading as accurate 'coretemp'? Anybody know where to get 'coretemp' from?)
fwelland is offline   Reply With Quote