View Single Post
Old 09-07-07, 06:36 AM   #1
Join Date: Jul 2003
Posts: 1,719
Default No AA for ATi in BioSHock
Originally Posted by Firing Squad & Dave Baumann of AMD
As it stands now, AA only works in BioShock’s DX9 mode, and only with GeForce hardware. We tried forcing AA with the Radeon HD 2900 XT under both Windows Vista and WinXP with all four custom filter AA modes (including edge detect) and couldn’t get AA to work properly in BioShock. We asked AMD if they plan on adding AA support to BioShock in a future Catalyst driver revision but couldn’t get a direct answer. The only way to enable AA under BioShock with Radeon cards is to rename the BioShock executable from “bioshock.exe” to “Oblivion.exe”. Keep in mind by doing this though, AMD’s driver-level optimizations for the game are automatically disabled, and as a result, performance suffers – we recorded a frame rate of just 26.7 fps for the 2900 XT with the executable renamed to Oblivion.exe running our manual walkthrough sequence under 4xAA at 1600x1200. (Surprisingly enough, the Radeon X1950 Pro delivered a frame rate of 20.9 fps under the exact same scenario) Because of this, AMD’s Dave Baumann told us flat out not to run the game with the renamed executable.
So, at this point anyway, ATi forces the end user to give up both good DX10 performance and anti aliasing in this game.
intel 990X + 2 X EVGA 3GB GTX580 + 3 X Acer GD235Hz
3D Vision Surround

Rig 2:
intel 2500K + NVIDIA GTX590 + Dell 3007 WFPHC

[SIZE="1"]NVIDIA Focus Group Member
[B]NVIDIA Focus Group Members receive free software and/or hardware from NVIDIA from time to time to facilitate the evaluation of NVIDIA products. However, the opinions expressed are solely those of the Members.[/B][/SIZE]
Rollo is offline   Reply With Quote