View Single Post
Old 09-12-07, 02:27 AM   #9
mvdlinde
Registered User
 
Join Date: Sep 2007
Posts: 1
Default Re: NVIDIA Xen 3.0 Patch for driver 100.14.11

I followed the short instructions I found here (but my link points to asm-x86_64), exported IGNORE_XEN_PRESENCE and got an error from the installer that no sources are installed.
Well, that is a thing I really don't understand because
Code:
sl103b3:~ # rpm -qa *header*
linux-kernel-headers-2.6.22-15
sl103b3:~ # rpm -qa kernel*
kernel-default-2.6.22.5-10
kernel-source-2.6.22.5-10
kernel-syms-2.6.22.5-10
kernel-xen-2.6.22.5-10
If I change 2 lines in NVidia*/usr/src/nv/conftest.sh the moduleinterface compiles and it works to load the module, but the attempt to start X ends with a kernelpanic.
The changes:
Code:
--- conftest.sh	2007-06-14 02:18:39.000000000 +0200
+++ conftest_custom.sh	2007-09-12 08:21:48.000000000 +0200
@@ -301,7 +301,7 @@
             # tree or at headers shipped for a specific kernel.
             # Determine the kernel version using a compile check.
             #
-            echo "#include <linux/autoconf.h>
+            echo "#include \"/usr/src/linux/linux/autoconf.h\"
             #include <linux/version.h>
             #include <linux/utsname.h>
             int main() {
@@ -312,7 +312,7 @@
               }
             }" > conftest$$.c
 
-            $HOSTCC $CFLAGS -o conftest$$ conftest$$.c > /dev/null 2>&1
+            $HOSTCC -o conftest$$ conftest$$.c #> /dev/null 2>&1
             rm -f conftest$$.c
 
             if [ -f conftest$$ ]; then
Any Ideas what to do now?

ml
mvdlinde is offline   Reply With Quote