Thread: TwinView help?
View Single Post
Old 06-06-03, 07:11 PM   #1
Asbel
Registered User
 
Join Date: Jun 2003
Posts: 5
Default TwinView help?

Okay, so I've tried everything in the ReadMe trying to get TwinView to work. I have a two-port GeForce 4 ti4600 (one VGA and one DVI adapted to VGA) with a CRT attached to the VGA and a LCD attached to the DVI. When I load up my edited XF86Config-4 I get an image on the second monitor, but nothing on the first. My XF86Config-4 is below, can anyone help me? Has anyone had this problem?
I've commented out the stuff I added, it's sort of a Xinerama/TwinView hybrid at the moment...


Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#Option "Xinerama" "on"
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbCompat" ""
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/usbmouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"
Identifier "BigOne"
VendorName "ViewSonic"
ModelName "ViewSonic PF795"
HorizSync 30-110
VertRefresh 50-180
EndSection

#Section "Monitor"
#Identifier "LittleOne"
#VendorName "Samsung"
#ModelName "SyncMaster 152B"
#HorizSync 30-60
#VertRefresh 50-75
#EndSection

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
# ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -v

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync # ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
# ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616

Section "Device"
Identifier "NVidiaCard"
VendorName "NVidia"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nv"
Option "DPMS"
#Option "TwinView" "true"
#Option "SecondMonitorHorizSync" "30-61"
#Option "SecondMonitorVertRefresh" "50-75"
#Option "MetaModes" "1024x768"
#Option "TwinViewOrientation" "LeftOf"
#Option "ConnectedMonitor" "CRT,CRT"
EndSection

Section "Screen"
Identifier "screen1"
Device "NVidiaCard"
Monitor "BigOne"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 15
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 16
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 24
Modes "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubsection
EndSection

#Section "Screen"
#Identifier "screen2"
#Device "NvidiaCard"
#Monitor "LittleOne"
#DefaultColorDepth 24

#Subsection "Display"
#Depth 24
#Modes "1024x768"#EndSubsection
#EndSection

Section "ServerLayout"
Identifier "Simple Layout"
Screen "Screen1"
#Screen "Screen2" LeftOf "Screen1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection
Asbel is offline   Reply With Quote