View Single Post
Old 09-15-07, 07:57 AM   #9
stefan42
Registered User
 
Join Date: Jul 2003
Posts: 51
Default Re: GeForce Go 7900 GS black flash screen

Did you already try to set the mysterious PerfLevelSrc option?
/etc/modprobe.d/options:
options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"

It's never been explained by nvidia what it does, but it's evident that it helps some people (including me) to avoid flickering and XID errors.
It seems to disable adjustment of clock frequencies and helped in my case to avoid the flickering on a 7900 Go GS (Dell 9400). Of course the GPU gets hotter without clocking down so use it with care.
stefan42 is offline   Reply With Quote