View Single Post
Old 06-12-03, 08:33 PM   #1
capoeirista
Registered User
 
Join Date: Mar 2003
Location: Hamvegas, New Zealand
Posts: 8
Unhappy Please Help with nvaudio dependencies!!

Hey, i've compiled the nforce drivers for my slackware 8.1 distribution, and the nvnet module loads, but not nvaudio. modules.conf complains that it can't load the module :
alias sound-slot-0 nvaudio

And when i try and insert the module manually, using /sbin/insmod nvaudio I get the following errors :

bash-2.05a$ /sbin/insmod nvaudio

Using /lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o

/lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_probe_codec

/lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o: unresolved symbol unregister_sound_dsp

/lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o: unresolved symbol register_sound_dsp

/lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o: unresolved symbol register_sound_mixer

/lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o: unresolved symbol unregister_sound_mixer

/lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_dac_rate

/lib/modules/2.4.18/kernel/drivers/sound/nvaudio.o: unresolved symbol ac97_set_adc_rate

So i'm guessing that i've missing some modules, but I don't know which ones. Can anyone give me a hand?

I did a depmod and this is what it told me, if it's of any use...

bash-2.05a$ /sbin/depmod nvaudio
# module id=string
# pci module vendor device subvendor subdevice class class_mask driver_data
# isapnp module cardvendor carddevice driver_data vendor function ...
# usb module match_flags idVendor idProduct bcdDevice_lo bcdDevice_hi bDeviceClass bDeviceSubClass bDeviceProtocol bInterfaceClass bInterfaceSubClass bInterfaceProtocol driver_info
# module pattern
# ieee1394 module match_flags vendor_id model_id specifier_id version
# module id
bash-2.05a$

Cheers,
Oliver Sneyd (Capoeirista)
capoeirista is offline   Reply With Quote