View Single Post
Old 10-29-07, 02:21 AM   #1
pargoo
Registered User
 
Join Date: Oct 2007
Posts: 2
Default using 96.43.01 with Solaris 10

Hi all.

I am struggling to get 1024x768 resolution out of Solaris 10 (version 6/06) on my old PIII, using a GeForce II MX100/200 AGP card running a CMV 1515 LCD monitor.
Initially, I screwed up my xorg.conf, but was still able to get X running satisfactorily using Xsun instead. However, I simply couldn’t get anything higher than 800x600x16-bit color no matter what entries I tried. Eventually I downloaded and installed the nVidia x86 drivers – version 96.43.01 – and on the spur of the moment gave the ‘sample’ xorg.conf file a spin. Much to my surprise, it worked (see below):


Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/X11/lib/X11/rgb"
ModulePath "/usr/X11/lib/modules"
FontPath "/usr/X11/lib/X11/fonts/TrueType/"
FontPath "/usr/X11/lib/X11/fonts/Type1/"
FontPath "/usr/X11/lib/X11/fonts/Type1/sun/"
FontPath "/usr/X11/lib/X11/fonts/F3bitmaps/"
FontPath "/usr/X11/lib/X11/fonts/misc/"
FontPath "/usr/X11/lib/X11/fonts/100dpi/"
FontPath "/usr/X11/lib/X11/fonts/75dpi/"
EndSection

Section "Module"
Load "IA"
Load "Xst"
Load "dbe"
Load "extmod"
Load "record"
Load "xtrap"
Load "glx"
Load "bitstream"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShadowFB" # [<bool>]
#Option "UseFBDev" # [<bool>]
#Option "Rotate" # [<str>]
#Option "VideoKey" # <i>
#Option "FlatPanel" # [<bool>]
#Option "FPDither" # [<bool>]
#Option "CrtcNumber" # <i>
#Option "FPScale" # [<bool>]
#Option "FPTweak" # <i>
Identifier "Card0"
Driver "nv"
VendorName "nVidia Corporation"
BoardName "NV11DDR [GeForce2 MX 100 DDR/200 DDR]"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
# SubSection "Display"
# Viewport 0 0
# Depth 1
# EndSubSection
# SubSection "Display"
# Viewport 0 0
# Depth 4
# EndSubSection
# SubSection "Display"
# Viewport 0 0
# Depth 8
# EndSubSection
# SubSection "Display"
# Viewport 0 0
# Depth 15
# EndSubSection
# SubSection "Display"
# Viewport 0 0
# Depth 16
# EndSubSection
SubSection "Display"
Viewport 0 0
Modes "1024x768" "800x600" "640x480"
Depth 24
EndSubSection
EndSection


However, although I can set the color depth to 24-bit for some reason I cannot get anything higher than 640x480. Can anyone suggest what I can add to boost my resolution? I was surprised because without horizontal and vertical rates entered I didn’t think it would work at all...
Many thanks!
pargoo is offline   Reply With Quote