View Single Post
Old 11-05-07, 08:19 AM   #1
thiebaut
Registered User
 
Join Date: Nov 2007
Posts: 1
Question Framelock crashes X server

In my project I use two machines, each one with :
- bi-Intel Xeon 3.06GHz
- one Quadro FX 3000G

The machines run on Fedora Core 4, with kernel 2.6.15-1.1831_FC4smp and nvidia driver 2.1.1 NVIDIA 100.14.09. Xorg is version 6.8.2.

After entering "xhost +" on each machine, I run the following script :

# - Make sure frame lock sync is disabled
nvidia-settings -a hpc-g02:0[gpu:0]/FrameLockEnable=0
nvidia-settings -a hpc-g01:0[gpu:0]/FrameLockEnable=0

# - Query the enabled displays on the GPUs
nvidia-settings -q hpc-g02:0[gpu:0]/EnabledDisplays
nvidia-settings -q hpc-g01:0[gpu:0]/EnabledDisplays

# - Check the refresh rate is the same for all displays
nvidia-settings -q hpc-g02:0[gpu:0]/RefreshRate
nvidia-settings -q hpc-g01:0[gpu:0]/RefreshRate

# - Make sure the display device we want as master is masterable
nvidia-settings -q hpc-g02:0[gpu:0]/FrameLockMasterable

# - Set the master display device (CRT-0)
nvidia-settings -a hpc-g02:0[gpu:0]/FrameLockMaster=0x00000001

# - Disable the house sync signal on the master device
nvidia-settings -a hpc-g02:0[framelock:0]/FrameLockUseHouseSync=1

# - Set the slave display devices
nvidia-settings -a hpc-g01:0[gpu:0]/FrameLockSlaves=0x00000001

# - Enable framelocking on server **** hangs
nvidia-settings -a hpc-g02:0[gpu:0]/FrameLockEnable=1

# - Enable framelocking on slave devices
nvidia-settings -a hpc-g01:0[gpu:0]/FrameLockEnable=1

# - Toggle the test signal
nvidia-settings -a hpc-g02:0[gpu:0]/FrameLockTestSignal=1
nvidia-settings -a hpc-g02:0[gpu:0]/FrameLockTestSignal=0

However, the system hangs on "nvidia-settings -a hpc-g02:0[gpu:0]/FrameLockEnable=1" and the X11 server crashes. I didn't found any solution yet.

Many thanks to anyone who can help,
Thiebaut.
thiebaut is offline   Reply With Quote