View Single Post
Old 11-05-07, 02:39 PM   #2
pigeon
Registered User
 
Join Date: Jul 2004
Posts: 57
Default Re: How to tell if you are using XvMC?

This might be more of a MythTV question, but anyway...

Try running mythfrontend at a terminal, then you will see messages like this when it is using XvMC:

Code:

2007-11-06 07:33:02.934 AFD: Opened codec 0x8ed9760, id(MPEG2VIDEO_XVMC) type(Video)
2007-11-06 07:33:02.935 AFD: Opened codec 0x8efa320, id(MP2) type(Audio)
2007-11-06 07:33:02.938 Opening ALSA audio device 'default'.
2007-11-06 07:33:03.240 VideoOutputXv: XvMCTex: Init failed
2007-11-06 07:33:03.240 VideoOutputXv: XvMC Adaptor Name: 'NV17 Video Texture'
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode:  140
  Minor opcode:  14
  Resource id:  0x273
2007-11-06 07:33:03.251 VideoOutputXv: Ack! Disabling ChromaKey OSD
			We can't use ChromaKey OSD if chromakeying is not supported!
2007-11-06 07:33:03.255 VideoOutputXv: XvMC Adaptor Name: 'NV17 Video Texture'
2007-11-06 07:33:03.540 TV: Changing from None to WatchingPreRecorded
2007-11-06 07:33:03.541 Realtime priority would require SUID as root.
Unable to launch application
XvMC: picture structure FRAME
For me, despite some of the warnings and errors above, it is playing using XvMC.

Note that XvMC (for most cards for now) only works with MPEG-2 video. See http://www.mythtv.org/wiki/index.php/XvMC for more info.
__________________
Geforce 6600 256MB RAM
Geforce Go 7400 256MB RAM
Geforce 9300M GS 256MB RAM (ASUS N10J)
ION 512MB RAM (Acer Revo)
GTX 460 1G RAM x 2
GeForce GT 335M (Alienware M11X R2)
pigeon is offline   Reply With Quote