View Single Post
Old 11-17-07, 04:42 PM   #25
levander
Registered User
 
Join Date: Nov 2007
Posts: 28
Default Re: SVideo works fine, Component gives no video at all

The component input X Screen is still in black and white.

Monitor section of my Xorg.conf where I've tried a couple of modelines I'm told are NTSC valid:
Code:
Section "Monitor"
	Identifier	"Television" # currently, the S-Video In port on the SyncMaster 215TW
	Modeline 	"720x480gtf"  26.72  720 736 808 896  480 481 484 497  -HSync +Vsync
	# from the bottom of http://www.realh.ukfsn.org/tvhowto/ar01s08.html
	ModeLine 	"720x480-ukfsn"  27.5  720 744 800 872  480 483 485 525 	
	# from https://scifi.homelinux.net/mediawiki/index.php/MythTV
	Mode "720x480-homelinux"
		# D: 34.563 MHz, H: 37.244 kHz, V: 73.897 Hz
		DotClock 34.564
		HTimings 720 752 840 928
		VTimings 480 484 488 504
		Flags	"-HSync" "-VSync"
	EndMode
	# from post #24 by philipl in http://www.nvnews.net/vbulletin/showthread.php?t=102252&page=2
	Modeline "720x480" 12.59 720 752 792 824 480 491 494 505 interlace
	# from post #2 by mc4man in http://ubuntuforums.org/showthread.php?p=3786463
	Modeline "720x480-mc4man" 27.000 720 736 798 858 480 489 495 525 -hsync -vsync
#	HorizSync	30-50
#	VertRefresh	60
EndSection
This is where in Xorg.0.log it looks like they are trying to explain why the 720x480 mode is not being used:
Code:
(II) NVIDIA(1): Frequency information for NVIDIA TV Encoder (TV-0):
(II) NVIDIA(1):   HorizSync   : 28.000-33.000 kHz
(II) NVIDIA(1):   VertRefresh : 43.000-72.000 Hz
(II) NVIDIA(1):     (HorizSync from Conservative Defaults)
(II) NVIDIA(1):     (VertRefresh from Conservative Defaults)
(II) NVIDIA(1): Note that the HorizSync and VertRefresh frequency ranges are
(II) NVIDIA(1):     ignored for TV Display Devices; modetimings for TVs will
(II) NVIDIA(1):     be selected based on the capabilities of the NVIDIA TV
(II) NVIDIA(1):     encoder.
(II) NVIDIA(1): 
(II) NVIDIA(1): --- Building ModePool for NVIDIA TV Encoder (TV-0) ---
(II) NVIDIA(1): --- Done building ModePool for NVIDIA TV Encoder (TV-0) ---
(II) NVIDIA(1): 
(II) NVIDIA(1): 
(II) NVIDIA(1): --- Modes in ModePool for NVIDIA TV Encoder (TV-0) ---
(II) NVIDIA(1): "nvidia-auto-select" :  800 x  600 @  60.3 Hz  (from: NVIDIA Predefined)
(II) NVIDIA(1): --- End of ModePool for NVIDIA TV Encoder (TV-0): ---
(II) NVIDIA(1): 
(II) NVIDIA(1): Assigned Display Device: TV-0
(II) NVIDIA(1): Requested modes:
(II) NVIDIA(1):     "720x480"
(WW) NVIDIA(1): No valid modes for "720x480"; removing.
(WW) NVIDIA(1): 
(WW) NVIDIA(1): Unable to validate any modes; falling back to the default mode
(WW) NVIDIA(1):     "nvidia-auto-select".
(WW) NVIDIA(1): 
(II) NVIDIA(1): Validated modes:
(II) NVIDIA(1): MetaMode "nvidia-auto-select":
(II) NVIDIA(1):     Bounding Box: [0, 0, 800, 600]
(II) NVIDIA(1):     NVIDIA TV Encoder (TV-0): "nvidia-auto-select"
(II) NVIDIA(1):         Size          : 800 x 600
(II) NVIDIA(1):         Offset        : +0 +0
(II) NVIDIA(1):         Panning Domain: @ 800 x 600
(II) NVIDIA(1):         Position      : [0, 0, 800, 600]
(II) NVIDIA(1): Virtual screen size determined to be 800 x 600
(==) NVIDIA(1): DPI set to (75, 75); computed from built-in default
See this in the output:
Quote:
modetimings for TVs will be selected based on the capabilities of the NVIDIA TV encoder.
I'm wondering if resolutions are based on "modetimings", and then according to that quote, there are only a few predefined sets of resolutions? And then, these would be the predefined modes available in my hardware TV encoder?
Quote:
(II) NVIDIA(1): --- Building ModePool for NVIDIA TV Encoder (TV-0) ---
(II) NVIDIA(1): --- Done building ModePool for NVIDIA TV Encoder (TV-0) ---
(II) NVIDIA(1):
(II) NVIDIA(1):
(II) NVIDIA(1): --- Modes in ModePool for NVIDIA TV Encoder (TV-0) ---
(II) NVIDIA(1): "nvidia-auto-select" : 800 x 600 @ 60.3 Hz (from: NVIDIA Predefined)
(II) NVIDIA(1): --- End of ModePool for NVIDIA TV Encoder (TV-0): ---
So, the only resolution available for me in HD480i is 800x600?

Lord knows nvidia could be a little more clearer in their debug statements, and answer the questions I'm asking now in them. Or, even answer these questions when they are posed in the forum they run?

nvidia-bug-report.log attached for the resolution offered by philip. It's the same one named "720x480" in my xorg.conf snippet above.
Attached Files
File Type: gz nvidia-bug-report.log.gz (33.8 KB, 105 views)
levander is offline   Reply With Quote