View Single Post
Old 11-18-07, 10:25 AM   #12
Doogman
Registered User
 
Join Date: Jul 2004
Posts: 21
Default Re: @Nvidia: OpenGL apps with compiz enabled run slower

Quote:
Originally Posted by Mr.A
I have done some testing with quake4 multiplayer Demo "playNetTimeDemo id_demo.ndmo86" and latest compiz svn.

My results are:
driver version | NVIDIA-Linux-x86-100.14.11
resolution | 1280x720

metacity | 99 fps
compiz | 84 fps (it never looks as smooth as without compiz)
As others have stated, this isn't really a Nvidia problem, but one with compiz. Compiz can't really distinguish between regular windows and 3D apps (games), so the game display has to run through the compiz "effects" code (even though nothing is happening) causing the slowdowns you have seen.

First, I have to respond to this:

Quote:
Originally Posted by lloeki
<snip>
as for "smoothness", sure I too lose a mere 5 fps in games, but it stays smooth nonetheless. hell, your 84fps is damn smooth, given that the human eye can only perceive ~25fps grand max.
The major assumption your are making is that the frame drops are occurring at a steady rate. Of course, this is wrong. What happens is that you get some time when no frame rate drop occurs and then a big blast of dropped frames which is very noticeable and much worse than a mere 5 fps of framerate loss would suggest.

The good news is that it's better than it used to be, but it's still a problem.

Ahhh, if only compiz had a setting so it would ignore full screen apps, allowing games to run at their full FPS without all that lag. But, wait, it does!

In Settings Manager/General/

Unredirect Fullscreen Windows

Unfortunately, the damn thing doesn't work properly. At this moment, it doesn't seem to help the FPS lags, but in UT2004 it does manage to steal the mouse focus so you can't play the game at all.

Alas, Unredirect Fullscreen Windows (UFW) is one of the buggiest features in compiz and has had a long history of not working, half-working and triggering other bugs. It seems most of the compiz developers don't use any other 3D apps at all besides compiz itself.

So, the solution to your problem is a working UFW setting in compiz, but this is the wrong forum to get a fix.
Doogman is offline   Reply With Quote