View Single Post
Old 11-18-07, 12:44 PM   #25
faba
Registered User
 
Join Date: May 2004
Posts: 16
Default Re: Blank virtual terminals

I see. Hmm, is there any way to use NoMaxPClkCheck for only some specific modes as using that option somehow causes the behavior that virtual terminals go blank...

EDIT

I fixed this issue by using reduced blanking modeline depicted in

http://www.nvnews.net/vbulletin/show...83&postcount=4

Which was

# 1680x1050 @ 60.00 Hz Reduced Blank (CVT)
# field rate 59.88 Hz; hsync: 64.67 kHz; pclk: 119.00 MHz
Modeline "1680x1050_60.00_rb" 119.00 1680 1728 1760 1840 1050 1053 1059 1080 +HSync -Vsync

together with few options

Option "ExactModeTimingsDVI"
Option "ModeValidation" "DFP-0: NoDfpNativeResolutionCheck"

I'm not really sure if it needs ExactModeTimingDVI option, but I included it anyways.

AS A RESULT, I have now working native resolution 1680x1050 and 1280x1024 framebuffer virtual terminals.
faba is offline   Reply With Quote