View Single Post
Old 11-20-07, 12:12 AM   #2
dahveed3
Registered User
 
Join Date: Sep 2007
Posts: 22
Default Re: Does 169.04 solve the "black window" issue?

I thought 100.14.19 already did that? Then 100.14.23 beta gave us the fix for exiting to virtual terminals with Compiz running (among some other stuff), and now we have the XV video turning into colorful, um, colors fix.

Just for information purposes, if you do install these and wind up with Compiz giving errors like No GLX FB Config for default depth, this isn't going to work, Failed to manage screen :0, or No manageable screens found on display :0.0, then the fix is to add another switch to Compiz startup command:

--no-libgl-fallback

This is actually an improvement I guess, since it'll only use direct rendering as opposed to automatically falling back to indirect (which now won't work at all anyway).

But if you use compiz-manager, you have to add that to the /usr/bin/compiz-manager under the options for loading Compiz.

So:

compiz --replace --no-libgl-fallback --sm-disable --ignore-desktop-hints ccp &

I think it does an export first, but if you do it yourself:

export __GL_YIELD="NOTHING"
compiz --blah, blah like above.

I haven't figured out how to add that to Fusion Icon's loading of Compiz yet, which makes Fusion Icon kind of useless. Compiz will just not start, and actually leave Kwin not being in charge either, without that --no-libgl-fallback with these new beta's.

Unless perhaps it doesn't effect your setup. Some folks were congratulating NVidia on the improvements while I was struggling to figure out why my Compiz was broken. I kept going back to 100.14.23 and seeing it work perfectly.

I'm on the new driver now and all seems well. Just gotta figure out the Fusion Icon problem. Editing /usr/lib/python/site-packages/FusionIcon/data.py didn't have any effect.
__________________
Epox EP-8KRAIPRO AthlonXP3200+ GeForce 6600GT 2x512MB PC3200 DDR-SDRAM SBLive 5.1 Platinum
dahveed3 is offline   Reply With Quote