View Single Post
Old 11-26-07, 07:48 PM   #29
Zapek
Registered User
 
Join Date: Sep 2007
Posts: 14
Default Re: GeForce Go 7900 GS black flash screen

Ok it works here. So there's definitely a problem when dynamic clocks are enabled. And the reason this gets noticed more in compiz than eg. plain 2D or games is because clocks vary a lot while using compiz. In 2D it seems to be low clocks everytime and when gaming it seems to be high clocks.

Anyway, so in ubuntu you'd have to add this:
Code:
options nvidia_new NVreg_Mobile=1 NVreg_RegistryDwords="PerfLevelSrc=0x2222"
in /etc/modprobe.d/nvidia-kernel-nkc
Mobile is probably not needed but I like having it to check that the arguments actually worked.

Finally I can use my card! Thanks to everyone involved.
Zapek is offline   Reply With Quote